Subject: [Healeys] Non Healey…but Lucas related

From: Stephen Hutchings via Healeys <[email-masked]>
Date: Tue, 21 May 2024 14:03:57 -0400

Hi Everyone,

I haven’t posted for a while, but that’s good…the car is running as it should!
I’m helping a friend with his series 2 Land Rover, the item of concern being the combination ignition / light switch. I know it was common to a number of British cars, and I know many of you are also into other British marques.
So…does anyone have a link to a good description, and or instructions on diagnosing/ dismantling this switch? I’ve found a few things online, but nothing as good as our trafficator instructions for Healeys, and the other resources on John Sims site.
Thanks,

Stephen, BJ8

Sent from my iPad
_______________________________________________
Support Team.Net http://www.team.net/donate.html
Suggested annual donation  $12.75

Archive: http://www.team.net/pipermail/healeys http://autox.team.net/archive/healeys

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

---

From: Patrick and Caroline Quinn via Healeys <[email-masked]>
Date: Wed, 22 May 2024 11:31:55 +0000

G'day

If you do find one, it would be appreciated if you could list it for everyone.

I have a real Healey that is fitted with one, and will be attending to the diabolical wiring shortly.

Many thanks

Patrick Quinn
Blue Mountains, Australia

-----Original Message-----
From: Healeys <[email-masked]> On Behalf Of Stephen Hutchings via Healeys
Sent: Wednesday, May 22, 2024 4:04 AM
To: Healeys <[email-masked]>
Subject: [Healeys] Non Healey…but Lucas related

Hi Everyone,

Stephen, BJ8

Sent from my iPad
_______________________________________________
Support Team.Net http://www.team.net/donate.html Suggested annual donation  $12.75

[email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]