Subject: Re: [Healeys] Lift for Healeys

From: Kent McLean <[email-masked]>
Date: Sun, 14 Oct 2018 15:16:38 -0400

Bob Spidell wrote:
> Space isn't an issue; my dad built a large 'barn'--that's what it's 
> shaped like, and what we call it--but it's really a large shop 
> URL: <http://autox.team.net/pipermail/healeys/attachments/20181014/0d66a155/attachment-0001.jpe>

Wow. Who did you have to kill for that?  I mean, Wow, nice shop.

A few years ago we bought a house with a 32x24 barn (with a few stalls for horses).  A year later my wife peeked in and said, “It looks like we’ve lived here for 20 years.”  I really need to start tossing some of my "treasures" so my kids don’t have to.

-
Kent McLean
’56 100 BN2
_______________________________________________
Support Team.Net http://www.team.net/donate.html
Suggested annual donation  $12.75

Archive: http://www.team.net/pipermail/healeys http://autox.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

---

From: Bob Spidell <[email-masked]>
Date: Sun, 14 Oct 2018 15:01:14 -0700

My late father had it built (in addition to a 3-car garage with 
bathroom).  Dad knew shops; he was an auto shop teacher for a while and 
designed the original automotive technology program at DeAnza College in 
Cupertino (I've known several mechanics making a good living after 
graduating from the program).  With his passing, I've inherited the task 
of maintaining all my family's vehicles (hence the need for a lift).  
The 'barn' is a lot more cluttered now, although the fire engine now 
belongs to the FD from which it originally came; one of my first tasks 
is to de-clutter it and effect some repairs.  As it is on a farm, there 
is lots of dust to deal with, as well as an invasion of mice and rats.  
It's a battle.

Bob

[email-masked]

---

From: Bob Spidell <[email-masked]>
Date: Tue, 23 Oct 2018 21:22:25 -0700

I've been a bit distracted by recent events, but I'm still researching 
lifts.  I called the '800' number for Greg Smith lifts, and talked a guy 
that (I think) was a distributor in Riverside, CA.  I mentioned I would 
prefer an American-made lift and he let slip--or was just being 
forthright, I can't say for sure--that all lifts save Mohawk brand were 
made in China (probably, they are made in China in one or a few 
factories but are distributed under various brands; the Greg Smith site 
cites a 'Texas company;'  check it out for some 'dirt' on lifts).  I'd 
not heard of Mohawk but, of course, I immediately stated googlin'. The 
Mohawk site has issues, but has some, er, 'interesting' information (see 
here:

http://mohawkliftpics.com/product-pictures/2-post-lifts/a-7/

... and look, in particular, under 'Comparison Photo Galleries'

One option is for 4 wheel cradles that effectively turn the lift into a 
4-post.   I really like this idea.

The Mohawk site doesn't list any prices, so it's one of those 'if you 
have to ask' things.  But, I'm OK buying a cheap made-in-China tool from 
Harbor Freight that probably will leak air but I might use 6 times in my 
lifetime, but getting under a lift with plastic wheels and cables, and 
welds that break makes me nervous.

Just passing what I've learned along.  This is a significant investment 
for me, and I'm inclined to spend extra up front for peace of mind.

Bob

[email-masked]

---

From: Richard Collins <[email-masked]>
Date: Wed, 24 Oct 2018 14:18:20 +0000

My Rotary Revolution 4post was Made in America when I bought and assembled myself 10-12 years ago.
I did substantial research and found the critical points, Chinese or not, was the weight of the steel used and the locking mechanism being failsafe as possible. A Chinese one I saw had ramps which Bent when driven on and off with a vehicle whose weight was well within its specs.
I went to several “good guys” hot rod shows and looked at various models on display. The quality differences are noticeable. The higher quality ones have certifications and insurance coverage as well.
Mine has paid for itself many times over.
Regards,
Richard C
BN7 440
And several other brands

> On Oct 24, 2018, at 1:23 AM, Bob Spidell <[email-masked]> wrote:
> 
> I've been a bit distracted by recent events, but I'm still researching lifts.  I called the '800' number for Greg Smith lifts, and talked a guy that (I think) was a distributor in Riverside, CA.  I mentioned I would prefer an American-made lift and he let slip--or was just being forthright, I can't say for sure--that all lifts save Mohawk brand were made in China (probably, they are made in China in one or a few factories but are distributed under various brands; the Greg Smith site cites a 'Texas company;'  check it out for some 'dirt' on lifts).  I'd not heard of Mohawk but, of course, I immediately stated googlin'. The Mohawk site has issues, but has some, er, 'interesting' information (see here:
> 
> One option is for 4 wheel cradles that effectively turn the lift into a 4-post.   I really like this idea.
> 
> The Mohawk site doesn't list any prices, so it's one of those 'if you have to ask' things.  But, I'm OK buying a cheap made-in-China tool from Harbor Freight that probably will leak air but I might use 6 times in my lifetime, but getting under a lift with plastic wheels and cables, and welds that break makes me nervous.
> 
> Just passing what I've learned along.  This is a significant investment for me, and I'm inclined to spend extra up front for peace of mind.
> 
> Bob
> 
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]
> 

[email-masked]

---

From: Bob Spidell <[email-masked]>
Date: Sun, 28 Oct 2018 08:34:29 -0700

Richard, et al,

Thanks to this, I looked into certification.  Found lots of good info 
here: https://www.autolift.org/

I've contacted Mohawk sales; still waiting for a reply from a 'local' 
distributor.

Bob

[email-masked]

---

From: Richard Collins <[email-masked]>
Date: Sun, 28 Oct 2018 16:51:05 +0000

Thanks as this is excellent info for the records.

Further FYI, I used to use a particular classic car insurance company (fairly well known) and part of the renewal program was to photo the secure area where my cars were kept. No big deal I thought until I soon received a nonRenewal/cancel notice from them. The reason? I had a lift in my garage !

After much unpleasantry between myself and the broker, they agreed to keep me covered if I submitted a limitation of liability letter to eliminate their risk of the lift from any claim I might submit.
With all the other liability limits they had, after many years of claimless premium paying to them, I dropped them ASAP and went elsewhere. 

Again, read the fine print of your policy and/or ask questions of your broker/underwriter or caveat emptor...

Regards,
Richard C
BN7 440

> On Oct 28, 2018, at 10:42 AM, Bob Spidell <[email-masked]> wrote:
> 
> Richard, et al,
> 
> Thanks to this, I looked into certification.  Found lots of good info here: https://www.autolift.org/
> 
> I've contacted Mohawk sales; still waiting for a reply from a 'local' distributor.
> 
> Bob
> 
> 

[email-masked]

---

From: Bob Spidell <[email-masked]>
Date: Sun, 28 Oct 2018 12:44:57 -0700

Ya gotta tell us: Hagerty or Grundy?

We have a couple cars with Hagerty; no issues yet (and they insured our 
100M for a fair value with only a few photos).

Bob

[email-masked]