Subject: [Fot] Recommend border x-ing

From: Lyman Scherer <[email-masked]>
Date: Sat, 25 Apr 2026 08:59:26 -0700

Traveling from Arizona to MoSport. Recommend which Canadian border crossing with truck and 24’ enclosed trailer?
Detroit area or Niagara Falls? 
Still undecided on bringing 12 five gallon jugs of $10/gal. Sunoco from AZ or buying fuel at track! Technically need to declare fuel at Customs.. is the hassle worth $$ savings?
Lyman #65 TR4
Sent from my iPhone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: [email-masked]
Date: Sat, 25 Apr 2026 14:44:10 -0400

I have never declared race fuel, and never had a problem!

Henry Frye

On 2026-04-25 11:59, Lyman Scherer wrote:
> Traveling from Arizona to MoSport. Recommend which Canadian border
> crossing with truck and 24’ enclosed trailer?
> Still undecided on bringing 12 five gallon jugs of $10/gal. Sunoco
> from AZ or buying fuel at track! Technically need to declare fuel at
> Customs.. is the hassle worth $$ savings?
> Lyman #65 TR4
> Sent from my iPhone
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/fot/[email-masked]