Subject: Re: [Fot] Shocks

From: Chuck Gee via Fot <[email-masked]>
Date: Fri, 24 Oct 2025 16:18:51 -0400

I talked with him a few months ago and he quoted me $300 each.  Hopefully you’ll get a better price!

Chuck

> On Oct 24, 2025, at 3:53 PM, Alfetta95 via Fot <[email-masked]> wrote:
> 
> Amici.  
> Lining up the winter projects. One of them are the shocks.   What are you guys running front/rear?  I still use the lever style in the rear.
> 
> And regarding the steel inserts into the aluminum rear drums.  I spoke with J&G Relining.  He is quoting me a price.  I will share. He’s done quite a few Datsun drums.  Sounds solid.  
> 
> Todd
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: DAVE HOGYE via Fot <[email-masked]>
Date: Sat, 25 Oct 2025 08:20:38 -0700 (PDT)

Hi Todd,
I have Spax up front, but they are too long for the TR3 once it's lowered.  The lower mount is spaced as to not let it bottom out. It would probably be fine to use on a car that is not lowered.  Good old Konis are a common choice for the front and the correct length.
On the rear, I'm using lever shocks from Peter Caldwell.
He rebuilds them and supplies three different levels.  Standard, heavy and adjustable, which I have.  It's a bleed valve plumbed between the piston bores to control flow.  They work great.  
Peter Caldwell
World Wide Auto Parts of Madison
2517 Seiferth Rd.
Madison WI USA 53716-3302
US WATS (800) 362-1025
(608) 223-9400
(608) 223-9403 fax

www.worldwideimportautoparts.com
www.nosimport.com

Dave H. 

> On 10/24/2025 12:43 PM PDT Alfetta95 via Fot <[email-masked]> wrote:
> 
>  
> Amici.  
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]