Subject: Re: [Fot] KCup 2026 at Mosport!

From: Chuck Gee via Fot <[email-masked]>
Date: Mon, 27 Oct 2025 08:45:34 -0400

Thanks Henry!  Is this race over Father’s Day weekend?  You’ve probably mentioned the dates before, but I didn’t put it on my calendar.

Chuck

> On Oct 27, 2025, at 8:10 AM, Henry Frye via Fot <[email-masked]> wrote:
> 
> As a lot of us are preparing for the cold weather to set in, getting ready for another off-season to go through our race cars, let's keep in mind that next year's Kastner Cup will be a return to where it all began, Mosport! I have been championing this race weekend for over 20 years, Mosport is an awesome track. If you thought Lime Rock felt fast, just wait!  Additionally, VARAC and our Canadian friends have written the book on hospitality. The VARAC Vintage Grand Prix is a very special event, think of it as having all the trappings of a big festival event, with none of the downsides of a big festival event!
> 
> This is just a reminder that everyone who needs to update or get their passport should not procrastinate. Who knows what our government shutdown will do to the Passport Office, but I think it is safe to say it will take longer than it would have if all government employees were back at their desks!
> 
> For those of us who believe the border crossing with a full race rig will be a problem, I will be sending more info on how we do it. I have coached many racers on the process over the years, and after they have done it once, they get it. It's no big deal. My rig is a 30-foot class A RV towing an enclosed trailer and have never had an issue at the border, both entering Canada and returning to the US. Please don't let the border crossing deter you from coming!
> 
> Stay tuned!
> 
> Henry Frye
> 2026 Kastner Cup Chair
> 860.508.3118
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Henry Frye via Fot <[email-masked]>
Date: Tue, 28 Oct 2025 05:14:14 -0400

You are correct, Chuck. Fathers Day weekend, June 18 - 21, 2026

I have been working a bit on www.kastnercup.com, and will be updating 
the website with all the pertinent information as it becomes available.

Henry Frye
2026 Kastner Cup Chair
860.508.3118

On 2025-10-27 08:45, [email-masked] wrote:
> Thanks Henry!  Is this race over Father’s Day weekend?  You’ve
> probably mentioned the dates before, but I didn’t put it on my
> calendar.
> 
> Chuck
> 
>> As a lot of us are preparing for the cold weather to set in, getting 
>> ready for another off-season to go through our race cars, let's keep 
>> in mind that next year's Kastner Cup will be a return to where it all 
>> began, Mosport! I have been championing this race weekend for over 20 
>> years, Mosport is an awesome track. If you thought Lime Rock felt 
>> fast, just wait!  Additionally, VARAC and our Canadian friends have 
>> written the book on hospitality. The VARAC Vintage Grand Prix is a 
>> very special event, think of it as having all the trappings of a big 
>> festival event, with none of the downsides of a big festival event!
>> 
>> This is just a reminder that everyone who needs to update or get their 
>> passport should not procrastinate. Who knows what our government 
>> shutdown will do to the Passport Office, but I think it is safe to say 
>> it will take longer than it would have if all government employees 
>> were back at their desks!
>> 
>> For those of us who believe the border crossing with a full race rig 
>> will be a problem, I will be sending more info on how we do it. I have 
>> coached many racers on the process over the years, and after they have 
>> done it once, they get it. It's no big deal. My rig is a 30-foot class 
>> A RV towing an enclosed trailer and have never had an issue at the 
>> border, both entering Canada and returning to the US. Please don't let 
>> the border crossing deter you from coming!
>> 
>> Stay tuned!
>> 
>> Henry Frye
>> 2026 Kastner Cup Chair
>> 860.508.3118