Subject: Re: [Fot] Lime Rock - driving there

From: Chuck Gee via Fot <[email-masked]>
Date: Thu, 21 Aug 2025 15:18:10 -0400

Thanks for that Scott!  I’m coming from the South, so maps has me coming up 87, cutting over on 84, and up the Taconic Parkway.  Based on your info, I should stay on 84 to Brewster and up 22?

Chuck

> On Aug 21, 2025, at 9:46 AM, Scott Janzen via Fot <[email-masked]> wrote:
> 
> One more thing that’s pretty critical for those of you who don’t know the region.  There are a number of “parkways”, for example the Taconic Parkway, the Merritt, etc, that don’t allow trailers or commercial vehicles.  Google maps will tend to route you on some of these, depending on where you are coming from, as they are often the most direct route.
> The only parkway in the region that allows trailers (but not tractor trailers) is the Garden State Parkway in NJ.
> Good luck - adds to the challenge!!!
> 
> On Aug 21, 2025, at 8:14 AM, yellow04 via Fot <[email-masked]> wrote:
> 
> We must be getting close, third post in a day!
> 
> Several racers contacted me who are travelling great distances and planning on arriving in the area on Monday. Without knowing what the parking situation is at their hotel/VRBO/AirBNB etc., they are looking for a safe place to drop their trailer overnight.
> 
> Attached is a marked-up satellite view of the track showing the area just outside registration that we have available for this purpose. The track does not allow camping out there, this space is only available on Monday evening assuming you are going to be returning to the track on Tuesday and running test day.
> 
> I also marked up Triumph Central in B Paddock, this is where we will be our home for the weekend!
> 
> Henry Frye
> 860.508.3118<Lime Rock Trailer parking.jpg>_______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 
> 
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Scott Janzen via Fot <[email-masked]>
Date: Thu, 21 Aug 2025 16:00:10 -0400

well, you could do that, and I guess I’ll check the travel time to see how it works out.  I thought I’d looked at that and it was a little slower, but it probably varies day to day.  I’ve been getting off 84 in Newburgh, going up 9W, across the river and through Poughkeepsie and up 44 to Lime Rock. Or, you can go up 87, but you have to overshoot Poughkeepsie and backtrack to get across the river.
Basically, every route involves a compromise and some local roads.

On Aug 21, 2025, at 3:18 PM, [email-masked] wrote:

Chuck