Subject: [Fot] Kastner Cup 2025 - Tech sheet and the Rules and Regs

From: yellow04 via Fot <[email-masked]>
Date: Sat, 16 Aug 2025 09:05:00 -0400

Racers,

This event manages tech a little differently than most. Each racer needs 
to print their tech sheet at home, fill it out and have it ready for our 
tech inspectors, Phil Gott and Mike Harmuth. After Phil or Mike signs 
off, they return the sheet to you, and on Thursday you take the tech 
sheet AND YOUR LOGBOOK to the nice volunteers in the Drivers Lounge 
where they complete the paperwork and hand you your tech sticker.

The good news is a lot of us will be at the track on Tuesday for the 
test day, and Mike Harmuth will be there as well with his Inspectors hat 
on, looking for Triumphs to get through the process. If you are running 
test day, please be ready for us to take a look at your stuff and we 
hope to knock out as many cars on Tuesday as possible!

Download the tech sheet here:

https://files.constantcontact.com/530f1ec0701/f0959a7c-bb35-4bff-88fd-ed081f2582a9.pdf

The track and VRG have issued the Sups for this event, please read this 
4 page document carefully and make sure you understand the requirements.

Download the 2025 Technical Regulations here:

https://files.constantcontact.com/530f1ec0701/8f06211c-0f76-4f3c-b70c-f09bbfa68bd7.pdf

The details are coming together nicely, this should be a fantastic 
weekend for us!

Cheers

Henry Frye
860.508.3118
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: Lyman Scherer via Fot <[email-masked]>
Date: Sat, 16 Aug 2025 10:19:08 -0700

#65 TR4A should be in Pit space Tuesday morning-noon time. Can offload for pre-Tech if possible.
Thanks 
Lyman 602-617-0991
Sent from my iPhone

> On Aug 16, 2025, at 6:19 AM, yellow04 via Fot <[email-masked]> wrote:
> 
> Racers,
> 
> This event manages tech a little differently than most. Each racer needs to print their tech sheet at home, fill it out and have it ready for our tech inspectors, Phil Gott and Mike Harmuth. After Phil or Mike signs off, they return the sheet to you, and on Thursday you take the tech sheet AND YOUR LOGBOOK to the nice volunteers in the Drivers Lounge where they complete the paperwork and hand you your tech sticker.
> 
> The good news is a lot of us will be at the track on Tuesday for the test day, and Mike Harmuth will be there as well with his Inspectors hat on, looking for Triumphs to get through the process. If you are running test day, please be ready for us to take a look at your stuff and we hope to knock out as many cars on Tuesday as possible!
> 
> The track and VRG have issued the Sups for this event, please read this 4 page document carefully and make sure you understand the requirements.
> 
> The details are coming together nicely, this should be a fantastic weekend for us!
> 
> Cheers
> 
> Henry Frye
> 860.508.3118
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]