Subject: [Fot] Perhaps the best GT6 Racing axle ever made.

From: Jason Ostrowski via Fot <[email-masked]>
Date: Tue, 12 Aug 2025 20:34:21 -0500

--Apple-Mail-24B0C845-B3DC-4F6F-979C-B09B17EDEFE9
	charset=us-ascii
Content-Transfer-Encoding: 7bit

--Apple-Mail-24B0C845-B3DC-4F6F-979C-B09B17EDEFE9
	name=image0.jpeg;
	x-apple-part-url=A5B75528-7BFC-448B-A6CB-F998BDF4C7C6-L0-001
Content-Disposition: inline;
	filename=image0.jpeg
Content-Transfer-Encoding: base64

--Apple-Mail-24B0C845-B3DC-4F6F-979C-B09B17EDEFE9
	charset=utf-8
Content-Transfer-Encoding: quoted-printable

We are lucky enough to own the axles shown.=20
Designed and  built in the early 1970=E2=80=99s, this original,  custom made=
,  GT6 Racecar axle set up has functioned without failure for overs 40 years=
.=20
In preparation for the Kastner Cup @ Lime Rock 2025 we decided to take it al=
l apart (take some notes) and restore the entire ensemble.=20
This last week has been fun and challenging.
Thanks goes to Daniel and Richard Gehweiler for helping me with the restorat=
ion.=20
For what it=E2=80=99s worth the set up is made from production car parts mad=
e prior to 1972.
TR6 GT6 and Chevy  =20
it has been so cool to dissect and rebuild this axle set as the original dea=
l.
I=E2=80=99m running it at lime rock.=20
What a fun hobby we have.
Jason Ostrowski=20
Friendly Ghost Racing=20
1969 Triumph GT6+ racecars

Sent from my iPhone=

--Apple-Mail-24B0C845-B3DC-4F6F-979C-B09B17EDEFE9
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

--Apple-Mail-24B0C845-B3DC-4F6F-979C-B09B17EDEFE9--

---

From: Chuck Gee via Fot <[email-masked]>
Date: Tue, 12 Aug 2025 22:04:36 -0400

Not even close, but I’m biased toward my own designs!

Looking forward to hanging out with you again Jason.  See you in a couple of weeks.

Chuck

> On Aug 12, 2025, at 9:52 PM, Jason Ostrowski via Fot <[email-masked]> wrote:
> 
> 
> We are lucky enough to own the axles shown.
> Designed and  built in the early 1970’s, this original,  custom made,  GT6 Racecar axle set up has functioned without failure for overs 40 years.
> In preparation for the Kastner Cup @ Lime Rock 2025 we decided to take it all apart (take some notes) and restore the entire ensemble.
> Thanks goes to Daniel and Richard Gehweiler for helping me with the restoration.
> For what it’s worth the set up is made from production car parts made prior to 1972.
> TR6 GT6 and Chevy   
> it has been so cool to dissect and rebuild this axle set as the original deal.
> I’m running it at lime rock.
> Jason Ostrowski
> Friendly Ghost Racing
> Sent from my iPhone_______________________________________________
> [email-masked]
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Charly via Fot <[email-masked]>
Date: Tue, 12 Aug 2025 21:18:09 -0500

I had a similar set up on my TR6, TR6 axel with Corvair hubs and a custom bearing mount.

Flawlee and period correct!!

Charly Mitchel 
Former TR6 #44

On Tue 12/08/25  6:34 PM , Jason Ostrowski via Fot [email-masked] sent:
> Designed and  built in the early 1970’s, this original,  custom
> made,  GT6 Racecar axle set up has functioned without failure for
> overs 40 years. 
> In preparation for the Kastner Cup @ Lime Rock 2025 we decided to
> take it all apart (take some notes) and restore the entire ensemble. 
> Sent from my iPhone
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/
> 
>

---

From: Brad Eells via Fot <[email-masked]>
Date: Tue, 12 Aug 2025 20:58:25 -0700

Jason, 

I own what Kas described as the prototype one piece axle for Spitfires. They were designed by my car’s original owner/builder/driver, Doug Brown, who worked with Kas. They were installed on his, and now mine 1969 Mk3.

I still have the original sketches for the design.

Kas said he wanted the hardest steel he could find. He called it Vasco Jet. He has it die forged and then machined.  They added a much larger Spicer yoke and U-Joint inboard.

Kas still had the U-Joint part number in a notebook.

I’ve always wondered how many sets of these axles were made. I have not found another confirmed set. 

Perhaps yours are? 

Brad Eells
Sent from my iPhone

> On Aug 12, 2025, at 7:22 PM, Chuck Gee via Fot <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>