Subject: Re: [Fot] Entries for the 2025 Kastner Cup race - Lime Rock Historics 43

From: Jason Ostrowski via Fot <[email-masked]>
Date: Tue, 10 Jun 2025 21:50:59 -0500

Lots of Triumph hero’s on that entry list. Friends, foes and all kinds of cool. 
This might be the best All Triumph race yet staged. 
I’m honored to be the obvious favorite driver on the the whole list.
 Jason Ostrowski 
Friendly Ghost Racing 
1969 Triumph GT6+ racecars.

Sent from my iPhone

> On Jun 10, 2025, at 6:24 AM, yellow04 via Fot <[email-masked]> wrote:
> 
> The entries for the Kastner Cup at Lime Rock stand at 35. Comparing the list of those who reached out to me several months ago showing their interest to the current entry list, I see many have not yet registered.
> 
> We have several moving parts involved planning the event, and it does make life easier on all the organizers if you folks who are intending on coming actually register sooner rather than later! The event has a liberal cancellation policy, you will receive a full refund if you cancel two weeks before the event, August 16th. So please register!
> 
> https://www.motorsportreg.com/events/historic-festival-43-race-car-entry-lime-rock-park-093569
> 
> Here is the list of our entries so far.
> 
> Schuster Vic AMBRO
> Brown Richard Spitfire
> Brown Thomas Spitfire
> Cutter David Spitfire
> Gagne Claude Spitfire
> Gosselin Kevin Spitfire
> Gussack David Spitfire
> Harmuth Mike Spitfire
> Janzen Scott GT6
> Ostrowski Jason GT6
> Schirano Brian GT6
> King Jeff GT6 Mk3
> Frymark John GT6+
> Fritz Lorne TR3
> Garmey Tony TR3
> McCurdy Rick TR3
> Styduhar John TR3
> Boruch Joe TR3A
> Redmond Todd TR3a
> Drews Tony TR4
> Gott Dave TR4
> Thompson Greg TR4
> Wheatley Mark TR4
> Gee Chuck TR4A
> Gott Phil TR4A
> Riddle Dave TR4A
> Howlett Brian TR-4A IRS
> Frye Henry TR250
> Cook Mark TR6
> Hollowell Walt TR6
> Horner Jaime TR6
> Kurtz Mike TR6
> Lang Bob TR6
> Podmore Tom TR6
> Schlesinger Alex TR7 coupe
> 
> I think this list is about 10 racers short of where I suspect we will end up. There are some obvious omissions, I have reached out to several folks who have indicated they are coming and will get right on that whole registration thing!
> 
> This is going to be a memorable event, it will be the first time we have gotten together and actually get some down time on Sunday to get to know Triumph racers we have perhaps emailed with but never met. A rough count shows we have 6 racers from the middle of the country, 4 racers from the west, and one from Canada! (Hi Claude, see you tomorrow at Mosport!)
> 
> Cheers
> 
> Henry Frye
> KCup chair, Lime Rock 2025 and Mosport 2026
> 860.508.3118
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Mark Bradakis via Fot <[email-masked]>
Date: Wed, 11 Jun 2025 03:07:30 -0600

> This might be the best All Triumph race yet staged.

And I am not going to be there, drat!  Sounds like a great weekend!

mjb.

---

From: Michael Moore via Fot <[email-masked]>
Date: Wed, 11 Jun 2025 12:15:43 +0000

Jason, I voted for you!

Have a Good Day
Mike

Michael T. Moore, CPA
3255 West 26th Street
Erie, PA 16506

Phone:  814-616-8652  ext 100
Fax:        888-865-5279
Email:    [email-masked]

This electronic mail message contains confidential and legally privileged information intended only for the use of the recipient. If the reader of this message is not the intended recipient, the reader is hereby notified that any dissemination, distribution, copying or other use of this message is strictly prohibited and is hereby instructed to notify the sender immediately by return email and destroy this copy of this message.

-----Original Message-----
From: Fot <[email-masked]> On Behalf Of Jason Ostrowski via Fot
Sent: Tuesday, June 10, 2025 10:51 PM
To: yellow04 <[email-masked]>
Cc: FOT <[email-masked]>
Subject: Re: [Fot] Entries for the 2025 Kastner Cup race - Lime Rock Historics 43

Sent from my iPhone

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]