Subject: [Fot] TR3 accelerator shaft bushings

From: Greg Blake via Fot <[email-masked]>
Date: Sun, 9 Feb 2025 18:21:17 -0600

Anyone have a source for these? Moss lists as NLA

Moss number 330-560
Sent from my iPhone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: Charly via Fot <[email-masked]>
Date: Sun, 9 Feb 2025 21:25:38 -0600

Might this work
https://bpnorthwest.com/triumph/
accelerator-shaft-bushing-kit-
heavy-duty-tr250-tr6/
Charly Mitchel 
TR6  #44

On Sun 09/02/25  4:21 PM , Greg 
Blake via Fot [email-masked] 
> Sent from my iPhone
________________________________
_______________
> fot@autox.
> team.net
> Donate: 
rchive: 
http://autox.team.net/archive
http://www.team.net/pipermail/fo
tUnsubscribe/Manage: 
http://autox.team.net/mailman/op
tions/fot/ch
> [email-masked]