Subject: [Fot] TR oil filter head bypass

From: Greg Blake via Fot <[email-masked]>
Date: Tue, 7 Jan 2025 19:42:50 -0600

Howdy folks,

Another dumb question as we are finishing the assembly of my son’s street TR3 motor. We are cleaning and refurbishing an old filter head off the spares shelf. We are using a later Tecalemit head and will be using a spin on filter adapter. 

So the dumb question. Is there any reason to retain the functionality of the pressure bypass valve on this filter head? My assumption is that we will be using a spin on filter with an integral bypass valve (most I’ve looked at range from 10-20 psi). So why retain the ball and spring bypass in the filter head? Isnt that redundant? Whats the preferred method to remove this internal bypass? Just a threaded plug?

Second related dumb question. What are yall using to replace the no longer available rubber seal that is used where the oil pressure adjustment valve screws into the side of the filter head? All of mine are severely dry rotted. Wondering if some form a gasket RTV is the go to here. 

Thanks for the help. 

Greg

Sent from my iPhone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: tr4 via Fot <[email-masked]>
Date: Tue, 07 Jan 2025 20:32:03 -0600

--===============1883494099752297421==

----_com.samsung.android.email_7698586296816310
Content-Transfer-Encoding: base64

----_com.samsung.android.email_7698586296816310
Content-Transfer-Encoding: base64

----_com.samsung.android.email_7698586296816310--

--===============1883494099752297421==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--===============1883494099752297421==--