Subject: [Fot] Race Car Windscreens

From: Ted Schumacher via Fot <[email-masked]>
Date: Thu, 26 Dec 2024 13:16:42 -0500

Hi List.  A Merry Christmas to all. We did a production run of race 
windscreens the day before Christmas. They fit all the TR's  except 
TR2/3. They also fit MGB, Datsun roadster and others.  Price is $175 + 
shipping.  Get together with your friends and ship several to one 
location (they are costly to ship due to size)  We did a run of 10 and 5 
are already sold to customers on waiting list.  Thanks in advance.  Ted

-- 
Ted Schumacher
[email-masked]
http://www.tsimportedautomotive.com
305 S. Jefferson St.
Pandora, Ohio, USA 45877
Phone: 800.543.6648 (US & Canada)
Tech/ Gen. Information/ Worldwide: 419.384.3022

_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: James Trudeau via Fot <[email-masked]>
Date: Thu, 26 Dec 2024 16:13:39 -0500

Thanks, Ted. 

Does this fit Spitfires? Or do you currently have any Spitfire windscreens available? 

What color is plexiglass (or Lexan) on these screens?

Sent from my iPhone

> On Dec 26, 2024, at 1:39 PM, Ted Schumacher via Fot <[email-masked]> wrote:
> 
> Hi List.  A Merry Christmas to all. We did a production run of race windscreens the day before Christmas. They fit all the TR's  except TR2/3. They also fit MGB, Datsun roadster and others.  Price is $175 + shipping.  Get together with your friends and ship several to one location (they are costly to ship due to size)  We did a run of 10 and 5 are already sold to customers on waiting list.  Thanks in advance.  Ted
> 
> --
> Ted Schumacher
> [email-masked]
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>