Subject: [Fot] Hardy Prentice

From: JOSEPH ALEXANDER via Fot <[email-masked]>
Date: Fri, 4 Aug 2023 15:46:42 -0500

I lost track of Hardy Prentice. Can anyone help me? I need to reach out to him.
Joe Alexander
4505 Donald Dr
Cedar Falls, IA 50613
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: "R. John Lye via Fot" <[email-masked]>
Date: Sat, 05 Aug 2023 12:12:20 -0400

The last email address that I had for Hardy was:

[email-masked]

Thanks,
John

On Fri, 4 Aug 2023 15:46:42 -0500, JOSEPH ALEXANDER via Fot <[email-masked]> wrote:

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]