Subject: Re: [Fot] Kastner Cup.

From: Brad Eells via Fot <[email-masked]>
Date: Tue, 25 Jul 2023 19:28:25 -0700

That would be fun.

The Spitfire made 3 consecutive appearances in the ARRC, 1971-73. All DNF…

Would be fun to get it back there and see a checkered flag.

Brad Eells
Sent from my iPhone

> On Jul 25, 2023, at 7:20 PM, Ronnie Babbitt via Fot <[email-masked]> wrote:
> 
> Is there any consideration to bringing the KCUP back to Road Atlanta During the Mitty. 
> 
> Ronnie
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Chuck Gee via Fot <[email-masked]>
Date: Tue, 25 Jul 2023 22:21:22 -0500

Would it have to be at the Mitty?

Chuck

> On Jul 25, 2023, at 9:26 PM, Ronnie Babbitt via Fot <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>

---

From: Terry Sopher via Fot <[email-masked]>
Date: Wed, 26 Jul 2023 06:40:18 +0200

That would be great!

> On Jul 26, 2023, at 04:20, Ronnie Babbitt via Fot <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>