Subject: [Fot] Bushings, Bazookas and smoke bombs.

From: Jason Ostrowski via Fot <[email-masked]>
Date: Mon, 22 May 2023 16:37:51 -0500

With this years quest to win the Kastner Cup. I couldn’t pass up the opportunity for an early in the season chance at some extra laps at Road America. So I entered the Spring Vintage weekend with SVRA.
I bit the bullet and paid the non-refundable $895 Knowing that my car was not quite ready for the track. 
I thrashed on the beast with a few sleepless nights and managed to get “pretty close” to being fully prepared.
In the off season we had put together a new cooling system and radiator, new fuel regulator and some fuel lines. On the final night, It came down to the wire as we happened to order a wrong adapter fitting for the fuel pressure gauge. I had the fitting express shipped to the track but without it, never got a chance to start the car prior to arrival at the glorious  kettle moraine. 
Anyway, the part arrived as hoped and everything that we had worked on looked good and seemed to be flowing nicely. 
It is typical that the first couple of starts for the season that I get a little weep of fuel drip coming from the bottom of my tried and true Stromberg 1.50’s. 
We had a little leak again this time but it finally stopped.  I had already missed the first session and still had to do the final safety check of the rear suspension.
That’s when I suddenly remembered that last season I had done a quick trackside fix to one of the rear wishbone bushings. It was tired and I had put a washer in place of a misshaped bushing. Well it had worked for that one last session. But it was not safe. 
How could I have forgotten something so critical. 
I felt shame. 
What would Kas have thought of this horrible miss in preparation?
With no spares on hand it seemed I was doomed.
Rescue came from 2 of Triumph’s best friends. 
- Richard And Dan Gehweiler Ageed to have me bring my wishbones to their shop for an 11th hour custom bushing making session. 
Richard started with a coffee can size chunk of Delron; chocked it in the lathe and let the plastic bits start flying. We measured everything to ultra precise micrometer readings  and about an hour later we had 4 of the best exact fit Steel sleeve bushings I have ever had. That’s a total A+ to the Stonefield Vintage boys!
Thank you!
I went back to the track and put everything back together. It was 10:30 pm and I had missed the entire 1st day.
Saturday morning I got the car through a tough and quite involved tech session and made a few laps in the qualifying session.
Basically just a shake down, bedding brakes, sniffing for leaks and feeling quite run down. 
Back in the paddock the fuel started leaking again.
We monkeyed with it a bit but didn’t really have the right parts to fix it correctly.   I fashioned some silicone tubing So that if it leaked on track it would drop below the frame and not on the headers.
Nothing to be proud of, but what I did.
I took the green flag For feature race 1 and kicked some Austin Healey and MGB ass.
Set my best time ever, 17th overall and 3rd in D production.
Sunday I had some great racing and moved up another couple spots to 11th overall and 2nd in D prod. Took home a nice little silver medallion.
Unknown to me at the time I got an email This morning from Eric “Jake” from FOT.
Telling me that he was watching from the inside of Canada corner and apparently there were flames shooting out from under my right wheelwell as the tube I made up acted like a bazooka type flame thrower. I guess every time I entered the braking zone the car started on fire.
Whoops!
I killed it in the race though.
The racing Gods punished me for living on the edge of burning it all down.
My van broke down on the way home and it looked like I had set off a smoke bomb on interstate 57.
Guess where... right on the exit ramp leading to the Gehweiler’s shop. 
Dan and Richard had to rescue me yet again. This time hauling my trailer back to their house and helping me and a cop limp my van to a safe place off the highway.
I got a ride back to Chicago from Brian Garcia ...carless, vanless. 
As I was Getting ready to head back home they asked me what I needed to grab out of my stuff...
I said “Only My Silver Medal”

Jason Ostrowski 
Friendly Ghost Racing 
1969 Triumph GT6+ racecars.
Sent from my iPhone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Chuck Gee via Fot <[email-masked]>
Date: Tue, 23 May 2023 19:16:30 -0400

Very nice Jason!  Looking forward to catching up in July!

Chuck

> On May 22, 2023, at 7:39 PM, Jason Ostrowski via Fot <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>