Subject: [Fot] Moving a spit

From: Christopher Bock via Fot <[email-masked]>
Date: Wed, 14 Dec 2022 19:55:05 -0500

Amici,

Anyone have some free space that can move a spit from Amherst, OH to VIR or the Raleigh/Durham NC area?

Chris 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: Susan Kahler via Fot <[email-masked]>
Date: Thu, 15 Dec 2022 06:47:01 -0500

The car is actually in the central Ohio area, south of Columbus. 

Sent from my iPhone

> On Dec 14, 2022, at 10:24 PM, Christopher Bock via Fot <[email-masked]> wrote:
> 
> Amici,
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]