Subject: [Fot] Fender transport from AZ to COTA

From: Greg Blake via Fot <[email-masked]>
Date: Sat, 29 Oct 2022 18:18:14 -0500

Trying to help a fellow gear head. If you are headed to COTA next weekend, passing thru NE AZ and willing to grab a pair of fenders, please contact me off list. Best way to get me is a text to my cell. 
512-917-3880

Thanks 
Greg

Sent from my iPhone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: Greg Blake via Fot <[email-masked]>
Date: Sat, 29 Oct 2022 18:27:20 -0500

Holbrook, AZ is where the fenders are

Sent from my iPhone

> On Oct 29, 2022, at 18:18, Greg Blake <[email-masked]> wrote:
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]