Subject: [Fot] Road America ELVF race report

From: Jason Ostrowski via Fot <[email-masked]>
Date: Wed, 21 Sep 2022 12:17:04 -0400

There are giggles in GT6 folklore about breaking the car on the trailer.
Not to be outdone by some hypothetical storyline, while backing the car off the trailer on Thursday afternoon the yellow Freindly Ghost Racing car refused to roll. How, why and when is unknown but she broke so well while being towed/unloaded that the differential became completely locked. 
This presented several problems. Getting it of the trailer was a real project. 
Once on the ground, it occurred to us that removal of the differential in the locked state would be no small task. 
Motivation came quickly thanks to Ace Triumph mechanic Dan Gehweiler. He offered me a spare to use for the weekend which was back at his shop down in Cedarburg about 30 minutes away. Even better, his crew guy Brian went to pick it up later in the evening. We got a freshly rebuilt unit delivered to the track just after nightfall. 
Since the Broken unit would not turn, it required the use of several tiny fingers many tiny tools and taking apart much more of the rear suspension than your typical diff drop. 
Thanks to teammates Brian Garcia and Dave and Alex Amys, we cursed and beat about the rear of the car for several hours and got everything put back together. I think I got to bed about 2 or 3 am so I would be fresh for the 7am drivers meeting. 
My neck was sore and my fingers were cramped, but the car was happy. We rolled out for the morning practice and put the car on the track for every session.
A big thanks to everyone who helped out and all the Triumph faithfull who stood around in the peanut gallery drinking beer and providing moral support.
Now for some quick Highlights Your Midwest FOT. 
The Alexanders brought out their TR4 with 3rd generation driver Brendan at the helm. 
Brendan got faster and faster as the weekend went on... ending up with a very respectable personal Best time. Grandpa Joe looked on with joy, as the boy almost nipped Joe’s own personal best TR4 time from back in the day. 
A great weekend for the Alexanders with The whole family cooking and crewing for all of us and uncle Mark sharing the car for the enduro. A+ for the team. 
Tony Drews was in his usual front running form in group 2 turning fast times and frustrating a few of the bathtub Porsche who own most of the top spots in group 2 at RA. 
Ryan Murphy also ran strong all weekend In his nicely prepared green TR4 #317. 
After working hard the last 2 months preparing a new motor for his spitfire, Dave Amys had a spring break and a keeper lost and had to end his weekend early due to valve and rocker unknowns.

The GT6 contingency was dominated by Alex Amys and Dan Gehweiler. These young whipper snappers have built And engineered 2 of the most beautiful GT6’s that I have ever seen. Taking the GT6 platform to levels that have never been seen. 
I also have to pat myself On the back for wielding my period correct Baby to some very hot laps with close racing and chasing. Finished every session and kept flogging it to the checkered. 
Alex had a scary moment at turn 5 sliding off track and ripping a tire off the rim. Apparently almost tipped the car over into the loose rocks of the kettle moraine. 
Dan also had a last lap glitch that forced him not to cross the line in his almost earned top finish. 
That allowed me to motor on to the top of the GT6 heap in Group 8; patting my tiny 50 year old 1.5 strombergs on their small throats.
The superior fire breath of the Modern  triple Webber cars will have to wait till next Time to show me up. Let’s hear it for the old school Friendly Ghost GT6+!
What a great weekend.
Again thanks to all that made my weekend successful.

Jason Ostrowski 
Friendly Ghost Racing 
1969 Triumph GT6+ racecars
Sent from my iPhone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Jason Ostrowski via Fot <[email-masked]>
Date: Wed, 21 Sep 2022 16:37:37 -0400

--Apple-Mail-602EB659-766C-4587-91C6-B3A9C01EF03B
	charset=us-ascii
Content-Transfer-Encoding: 7bit

--Apple-Mail-602EB659-766C-4587-91C6-B3A9C01EF03B
	name=image1.jpeg;
	x-apple-part-url=33FC301E-1D0A-4356-AEBD-E66C68163801-L0-001
Content-Disposition: inline;
	filename=image1.jpeg
Content-Transfer-Encoding: base64

--Apple-Mail-602EB659-766C-4587-91C6-B3A9C01EF03B
	charset=utf-8
Content-Transfer-Encoding: quoted-printable

Here is a nice shot from the inside of Canada corner.
Sent from my iPhone

> On Sep 21, 2022, at 4:10 PM, DENNIS WALJE <[email-masked]> wrote:
>=20
> =EF=BB=BFHow about any race pics?
>=20
> Dennis Walje
> 68 GT6=20
>=20
> Sent from my iPhone
>=20
>> On Sep 21, 2022, at 11:58 AM, Jason Ostrowski via Fot <[email-masked]=
> wrote:
>>=20
>> =EF=BB=BFThere are giggles in GT6 folklore about breaking the car on the t=
railer.
>> Not to be outdone by some hypothetical storyline, while backing the car o=
ff the trailer on Thursday afternoon the yellow Freindly Ghost Racing car re=
fused to roll. How, why and when is unknown but she broke so well while bein=
g towed/unloaded that the differential became completely locked.=20
>> This presented several problems. Getting it of the trailer was a real pro=
ject.=20
>> Once on the ground, it occurred to us that removal of the differential in=
 the locked state would be no small task.=20
>> Motivation came quickly thanks to Ace Triumph mechanic Dan Gehweiler. He o=
ffered me a spare to use for the weekend which was back at his shop down in C=
edarburg about 30 minutes away. Even better, his crew guy Brian went to pick=
 it up later in the evening. We got a freshly rebuilt unit delivered to the t=
rack just after nightfall.=20
>> Since the Broken unit would not turn, it required the use of several tiny=
 fingers many tiny tools and taking apart much more of the rear suspension t=
han your typical diff drop.=20
>> Thanks to teammates Brian Garcia and Dave and Alex Amys, we cursed and be=
at about the rear of the car for several hours and got everything put back t=
ogether. I think I got to bed about 2 or 3 am so I would be fresh for the 7a=
m drivers meeting.
>> My neck was sore and my fingers were cramped, but the car was happy. We r=
olled out for the morning practice and put the car on the track for every se=
ssion.
>> A big thanks to everyone who helped out and all the Triumph faithfull who=
 stood around in the peanut gallery drinking beer and providing moral suppor=
t.
>> Now for some quick Highlights Your Midwest FOT.=20
>> The Alexanders brought out their TR4 with 3rd generation driver Brendan a=
t the helm.=20
>> Brendan got faster and faster as the weekend went on... ending up with a v=
ery respectable personal Best time. Grandpa Joe looked on with joy, as the b=
oy almost nipped Joe=E2=80=99s own personal best TR4 time from back in the d=
ay.=20
>> A great weekend for the Alexanders with The whole family cooking and crew=
ing for all of us and uncle Mark sharing the car for the enduro. A+ for the t=
eam.=20
>> Tony Drews was in his usual front running form in group 2 turning fast ti=
mes and frustrating a few of the bathtub Porsche who own most of the top spo=
ts in group 2 at RA.=20
>> Ryan Murphy also ran strong all weekend In his nicely prepared green TR4 #=
317.=20
>> After working hard the last 2 months preparing a new motor for his spitfi=
re, Dave Amys had a spring break and a keeper lost and had to end his weeken=
d early due to valve and rocker unknowns.
>>=20
>> The GT6 contingency was dominated by Alex Amys and Dan Gehweiler. These y=
oung whipper snappers have built And engineered 2 of the most beautiful GT6=E2=
=80=99s that I have ever seen. Taking the GT6 platform to levels that have n=
ever been seen.
>> I also have to pat myself On the back for wielding my period correct Baby=
 to some very hot laps with close racing and chasing. Finished every session=
 and kept flogging it to the checkered.=20
>> Alex had a scary moment at turn 5 sliding off track and ripping a tire of=
f the rim. Apparently almost tipped the car over into the loose rocks of the=
 kettle moraine.=20
>> Dan also had a last lap glitch that forced him not to cross the line in h=
is almost earned top finish.=20
>> That allowed me to motor on to the top of the GT6 heap in Group 8; pattin=
g my tiny 50 year old 1.5 strombergs on their small throats.
>> The superior fire breath of the Modern  triple Webber cars will have to w=
ait till next Time to show me up. Let=E2=80=99s hear it for the old school Fri=
endly Ghost GT6+!
>>=20
>> Jason Ostrowski=20
>> Friendly Ghost Racing=20
>>=20
>>=20
>> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/walje@sbcgl=
obal.net
>>=20
>>=20
>=20

--Apple-Mail-602EB659-766C-4587-91C6-B3A9C01EF03B
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--Apple-Mail-602EB659-766C-4587-91C6-B3A9C01EF03B--