Subject: [Fot] Nominations for Induction into the British Sports Car of Fame.

From: Joe Alexander via Fot <[email-masked]>
Date: Sun, 24 Jul 2022 09:36:11 -0500

Nominations are now open for the britishsportscarhalloffame.org.

Public nominations are encouraged. The Triumph Community is already nicely represented, as it should be.  Some names that come to mind:

David Hobbs.   Drove for Kas 
Brian Redman. 
John Buffum.  Greatest North American Rally Driver with Triumphs.
Donna Mae Mims. SCCA Nat’l Champion and did compete in a TR3

The HOF Board of Directors will NOT nominate candidates, so it is up to you guys to nominate and promote your candidates.

Throw some names out there and go to the HOF Website to submit.

Thank you very much.

Joe Alexander
4505 Donald Dr
Cedar Falls, IA 50613
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Greg Petrolati via Fot <[email-masked]>
Date: Sun, 24 Jul 2022 18:09:06 +0000

I’ll vote for Donna Mae Mims… because this ain’t a sausage party only…

Sent from my iPhone

> On Jul 24, 2022, at 8:25 AM, Joe Alexander via Fot <[email-masked]> wrote:
> 
> https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.fot-racing.com%2F&amp;data=05%7C01%7C%7Cdefd004ef5c84d900c1608da6d88ac8d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637942731019114810%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&amp;sdata=6o1Tdvt%2Fm3omszn53lpEqVy5v8l9rEgZ8u97q90bEFc%3D&amp;reserved=0
> 
> Donate: https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.team.net%2Fdonate.html&amp;data=05%7C01%7C%7Cdefd004ef5c84d900c1608da6d88ac8d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637942731019114810%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&amp;sdata=4LxqjOOqeupxk4W30k6GzQoMqYX%2F2KmrzYDNK6X2Kek%3D&amp;reserved=0
> Archive: https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fautox.team.net%2Farchive&amp;data=05%7C01%7C%7Cdefd004ef5c84d900c1608da6d88ac8d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637942731019114810%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&amp;sdata=G25uZUbzAUumaoRQFSSJS5QiDeJYei4hrN9hA7l0qJc%3D&amp;reserved=0 https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.team.net%2Fpipermail%2Ffot&amp;data=05%7C01%7C%7Cdefd004ef5c84d900c1608da6d88ac8d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637942731019114810%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&amp;sdata=KMQniijmvH8I%2BpxZ5MKw7Qn2tSQcrz9Cv5EV2ia5cjk%3D&amp;reserved=0
> Unsubscribe/Manage: https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fautox.team.net%2Fmailman%2Foptions%2Ffot%2Fgreenman62%40hotmail.com&amp;data=05%7C01%7C%7Cdefd004ef5c84d900c1608da6d88ac8d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637942731019114810%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&amp;sdata=OxB2uSrdKvu4rgawq950Z3yez1EuxfNts2VodUzwjqU%3D&amp;reserved=0
> 
>