Subject: [Fot] SCCA Time Trial car rules and Swamp cooler info

From: Bud Rolofson via Fot <[email-masked]>
Date: Mon, 3 Jan 2022 15:00:45 -0700

Listerati,

After wading through 53 pages of the 727 pages of SCCA GCR regs I thought I’d see if someone knew where I can more easily find a list of what’s allowed and/or not allowed on cars racing in SCCA Time Trials. I’m trying to figure out how close I am to being able to run with my current setup.

Thanks
Bud

P.S. For those VTR members that saw the swamp cooler article in the latest VTR magazine there’s one important bit of info that needs clarification. The size of the tubing that attaches to the scuttle vent is 5/32” x 014 brass tubing, not 1/2” pipe. 1/2” would drain your windshield water reservoir pretty quick. :)

If anyone decides to do the swamp cooler modification and wants more details/pictures contact me.
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "rocky spitfire4.com via Fot" <[email-masked]>
Date: Mon, 3 Jan 2022 22:30:41 +0000

You may find SCC Time Trials is largely run what ya brung. While there are categories and classes, assuming you're not bringing a Formula car, there's someplace for your hot rod to slot into.

"Time Trials—first and foremost—is about the quest for speed. This is a place for mechanical creativity, driver development and envelope pushing. There is no room here for balance of performance, spec classes or slowing down the fast to make a better show."

Check these links:
• timetrials.scca.com
And under the header "What Is TT?"
• timetrials.scca.com/pages/philosophy
• timetrials.scca.com/pages/safety

--Rocky Entriken

-----Original Message-----
From: Fot <[email-masked]> On Behalf Of Bud Rolofson via Fot
Sent: Monday, January 3, 2022 4:01 PM
To: FOT <[email-masked]>
Subject: [Fot] SCCA Time Trial car rules and Swamp cooler info

Listerati,

Thanks
Bud

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]