Subject: [Fot] A Little Levity

From: Paul Ricco via Fot <[email-masked]>
Date: Tue, 11 May 2021 18:01:24 -0500

--Apple-Mail-75915E09-C8E6-4495-8B6B-497D59986F87
	charset=utf-8
Content-Transfer-Encoding: quoted-printable

Why not?

The big red sticker on the back car says =E2=80=9CTOW=E2=80=9D and it is a t=
ractor motor.....

We Hope to see some of you at Road America this weekend.=20

Paul Ricco

--Apple-Mail-75915E09-C8E6-4495-8B6B-497D59986F87
	name=IMG_3802.jpg;
	x-apple-part-url=CC8BAA2F-F5B8-4754-AAC6-35CF80FC2F0A
Content-Disposition: inline;
	filename=IMG_3802.jpg
Content-Transfer-Encoding: base64

--Apple-Mail-75915E09-C8E6-4495-8B6B-497D59986F87
	charset=us-ascii
Content-Transfer-Encoding: 7bit

Sent from my iPhone
--Apple-Mail-75915E09-C8E6-4495-8B6B-497D59986F87
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

--Apple-Mail-75915E09-C8E6-4495-8B6B-497D59986F87--

---

From: Joe Alexander via Fot <[email-masked]>
Date: Tue, 11 May 2021 18:04:22 -0500

We will be there. Circling the wagons.

Joe Alexander
4505 Donald Dr
Cedar Falls, IA 50613
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

> On May 11, 2021, at 6:01 PM, Paul Ricco via Fot <[email-masked]> wrote:
> 
> Why not?
> 
> The big red sticker on the back car says “TOW” and it is a tractor motor.....
> 
> We Hope to see some of you at Road America this weekend. 
> 
> Paul Ricco
> 
> 
> Sent from my iPhone_______________________________________________
> [email-masked]
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: yellow04 via Fot <[email-masked]>
Date: Wed, 12 May 2021 06:07:18 -0400

Big contingent of FOT at Summit Point this weekend, home of the 2015 
Kastner Cup.

MIA this weekend is John Hasty, impatiently waiting for his new-to-him 
TR3B to get prepped for action. We will miss you John but looking 
forward to seeing you back on track soon!