Subject: [Fot] TR3 rear hub bearings

From: Greg Blake via Fot <[email-masked]>
Date: Sun, 18 Oct 2020 17:15:52 -0500

Does anyone have the Timken numbers for the bearing and race for the stock late style TR3 rear axle hubs?  Rebuilding one for my son’s car and have all the differential bearings, but need to source new bearings for the hubs. 

Thanks. 

Greg

Sent from my iPhone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Greg Blake via Fot <[email-masked]>
Date: Sun, 18 Oct 2020 20:18:30 -0500

Thanks everyone for the responses. 

They are:
Timken bearing is #2585
Timken race is #2523

I’ve ordered them from RockAuto

Sent from my iPhone

> On Oct 18, 2020, at 5:16 PM, Greg Blake <[email-masked]> wrote:
>