Subject: Re: [Fot] spitfire/gt6 door handles

From: Phil Gott via Fot <[email-masked]>
Date: Sat, 15 Feb 2020 07:09:22 -0500

Terry:
If you have a part number or a picture, I might be able to help. I have some NOS door handjes, some in their Stanparts boxes, but being a TR4 guy, I don’t know what they fit.
Phil Gott

Sent from my iPhone

> On Feb 15, 2020, at 4:40 AM, Enquiries Road & Track via Fot <[email-masked]> wrote:
> 
> 
> does anyone know of a plastic replacement for the die cast original inside door opening and window winder handles ??. i'm guessing the square "peg" drive is common to other cars of the era and my recollection is BMC 1100's and such had the same. I'm looking for a weight saving in the race car and at the same time getting rid of some 50 year old bits that look decidedly tatty as the chrome is all bubbling from core metal breakdown
> 
> thanks
> 
> Terry
> 
> 
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Phil Gott via Fot <[email-masked]>
Date: Sat, 15 Feb 2020 07:09:22 -0500

Terry:

Sent from my iPhone