Subject: [Fot] Historically Significant Triumph Race Cars. Display at The Glen. Two Triumphs needed.

From: Joe Alexander via Fot <[email-masked]>
Date: Wed, 22 May 2019 16:30:44 -0500

FOT:

We are looking for two candidates for display.

They would be on display in the IMRRC Facility at Watkins Glen for at least the duration of the SVRA event in September 2019.

The candidate Cars could not do double duty as a race entry, but COULD be released for the re-enactment on Friday.

Any suggestions would be appreciated.

Thank you.

Joe Alexander
4505 Donald Dr
Cedar Falls, IA 50613
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: Phil Gott via Fot <[email-masked]>
Date: Wed, 22 May 2019 22:44:14 -0400

Tim Sudard’s Ex Daytona TR 3?

Sent from my iPhone

> On May 22, 2019, at 5:30 PM, Joe Alexander via Fot <[email-masked]> wrote:
> 
> FOT:
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]