Subject: Re: [Fot] Lodging for Watkins Glen

From: Bill Tobin via Fot <[email-masked]>
Date: Thu, 1 Nov 2018 23:39:41 -0400

Hi Tony, yes the Seneca Lodge is good, as is the Glen Motor Inn; these 
two are the more historic places to stay. Full disclosure, I'm friends 
with the Glen Motor Inn's owners.

Lots of newer places too.

There is a KOA campground a few miles from the track. A bunch of us 
rented  a couple of KOA Kabins there when we went up and ran a 1/2 
marathon in Corning last October. Very modern cabins. Lots of lodging in 
Corning too.

Hope to see you there.

Bill

On 11/1/2018 7:38 PM, Tony Drews via Fot wrote:
> Is the Seneca Lodge still the place to shoot for when at Watkins Glen?
>
> Regards, Tony
>
> _______________________________________________
> [email-masked]
>
> http://www.fot-racing.com
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/pipermail/fot
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/fot/[email-masked]
>
>

_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Bill Dentinger via Fot <[email-masked]>
Date: Thu, 1 Nov 2018 23:41:41 -0400

--===============5998654302701469039==
	boundary="----=_Part_8153_338883569.1541130101637"

------=_Part_8153_338883569.1541130101637
Content-Transfer-Encoding: 7bit

It was always a great place for steak dinner, but pretty primitive for lodging.  Their bar is GREAT and is like the Siebkins of Watkins Glen.  

We always stayed in Horseheads (about 20-25 minutes East of the track.  Nice Best Western Hotel, and a great Tavern/Restaurant on the grounds that served both Italian and Chinese food.  The husband was Italian, and the wife was Chinese.

Bill

Sent from AOL Mobile Mail
Get the new AOL app: mail.mobile.aol.com

On Thursday, November 1, 2018, Tony Drews via Fot <[email-masked]> wrote:

Regards, Tony

------=_Part_8153_338883569.1541130101637
Content-Transfer-Encoding: 7bit

<br><div class="aolmail_replyHeader">
    On&nbsp;Thursday, November 1, 2018,&nbsp;Tony Drews via Fot&nbsp;&lt;[email-masked]&gt;&nbsp;wrote:
</div><br>
------=_Part_8153_338883569.1541130101637--

--===============5998654302701469039==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--===============5998654302701469039==--