Subject: Re: [Fot] Amelia Island. Exciting.

From: Mike Deweerd <[email-masked]>
Date: Mon, 7 Nov 2016 14:00:47 -0500

Is there Motorhome parking/camping at the Track (Sebring) 
Anyone know of Motorhome rentals near the track? 
Thanks 
Mike Deweerd 

Sent from my iPhone

> On Nov 2, 2016, at 10:23 AM, Joe Alexander <[email-masked]> wrote:
> 
> FOT:
> 
> Thanks for all of the responses.
> 
> My next step is to ask Bill Warner if his proposed "Six Triumphs" is a limit, or would he accept more.
> 
> I am going to summarize the submittals and forward to him today. Will publish the results.
> 
> ---------------------
> 
> It will be a big year for the FOT in 2017
> 
> Amelia Island and Sebring for some.
> 
> The Kastner Cup at Black Hawk Farms. (There is something magical going on with that event. A converging perfect storm of compelling elements....whatever that means.
> 
> Regards,
> 
> Joe Alexander
> 645 1st Street
> Jesup, IA 50648
> The-vintage-racer.com
> Gasketinnovations.com
> Cell:  319.464.4711
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Joe Alexander <[email-masked]>
Date: Mon, 7 Nov 2016 13:11:47 -0600

Motorhome Parking is a very dominant part of the Sebring Experience.

Rentals can be had as package deals. Google motorhome rentals in Florida.

Big year for Triumph.

Amelia Island
Sebring
Kastner Cup.

Now we have Moss sponsoring a British Sports Car Hall of Fame Induction in June of 2017. There are eight FOT listed as nominees and voting is going on thru Moss.

A good way to support our Triumph Marque.

Joe Alexander
645 1st Street
Jesup, IA 50648
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

> On Nov 7, 2016, at 1:00 PM, Mike Deweerd <[email-masked]> wrote:
>