Subject: [Fot] Interesting TR-7 racer on ebay (not vintage)

From: Tony Drews <[email-masked]>
Date: Fri, 27 May 2016 11:54:58 -0500

http://bringatrailer.com/2016/05/26/scca-e-productionecta-land-speed-record-racer-1978-triumph-tr7/

Tony

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: "J.C. Hassall" <[email-masked]>
Date: Fri, 27 May 2016 16:16:36 -0400

I like speed as much as the next guy but that just looks wrong

jim

Fat-thumbed from my iPhone

> On May 27, 2016, at 12:54 PM, Tony Drews <[email-masked]> wrote:
> 
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>