Subject: [Fot] Oil cooler yes or no?

From: Steven Belfer <[email-masked]>
Date: Mon, 8 Feb 2016 09:42:35 -0800

Do you run an oil cooler on your racing Triumph?

I’m having a tough time getting access to the hoses on the oil cooler adapter plate, it’s such a tight fit and I forgot to attach them before installing the engine.
It’s a huge pain to take off the oil filter plate with the motor installed!

Wondering if the oil cooler is even necessary. I race in California where it is over 90 degrees some of the time.

~STEVE

_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: <[email-masked]>
Date: Mon, 8 Feb 2016 18:35:15 +0000

I am also in Texas and I wouldn't run without a cooler because of the hot temps in general and the added benefit of the extra oil in the system. The lines that come with the kits on TR3's are very difficult to manipulate as you have noticed. Some come with BSP (British Std. Pipe) fittings. Why not switch out to an AN setup and use a cut to fit hose set up and route the hoses over the top of the inner fender. You can get the push on hose and fittings in black and it looks pretty nice even on period correct cars. 

Bob Kramer
[email-masked]

~STEVE

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 8 Feb 2016 14:30:08 -0800

Steve, 
   I have run a 15 row oil cooler on my car ever
since I have been racing it. At Willow Springs on a
hot day, with the oil uncovered, I have seen 230
degrees + on my oil temp gauge. I like to keep my oil
temp over 180 degrees and less than 220 degrees. On
the dyno, there is a measurable increase in power
with the oil temp close to 200 degrees. There have
been cold days when I have covered the cooler and
been tempted to cover the finned alloy oil pan. My
alloy pan holds 8 quarts of oil. It is a very
efficient cooler all by itself, but not good enough
for racing hard on a hot day. I use Brad Penn 20w-50
or Valvolene VR1 20-50 racing oil. I like to see 85 -
90 psi oil pressure when hot at 6,000 RPM. 

Greg Solow
The Engine Room
Sports Car Specialists
Santa Cruz, CA 95060
831 429-1800

------- Original Message -------
From    : Steven Belfer[mailto:[email-masked]]
Sent    : 2/8/2016 9:42:35 AM
To      : [email-masked]
Cc      : 
Subject : RE: [Fot] Oil cooler yes or no?

I’m having a tough time getting access to the hoses
on the oil cooler adapter plate, it’s such a tight
fit and I forgot to attach them before installing the
engine.
It’s a huge pain to take off the oil filter plate
with the motor installed!

Wondering if the oil cooler is even necessary. I race
in California where it is over 90 degrees some of the
time.

~STEVE

Donate:  http://www.team.net/donate.html 
Archive:  http://www.team.net/archive 
Forums:  http://www.team.net/forums 
Unsubscribe/Manage: 
http://autox.team.net/mailman/options/fot/[email-masked]