Subject: [Fot] VARA SoCal races near 2016 Kastner Cup

From: Steven Belfer <[email-masked]>
Date: Fri, 16 Oct 2015 10:59:08 -0700

Dear FOT,  I've been off the list for a while but I'm glad to be back. Dave H and I are organizing the 2016 Kastner Cup, April 1-3 at beautiful Sonoma Raceway. We just raced there a couple weeks ago and I can assure you, it's a top-notch venue and CSRG is thrilled to have us. 
For those of you planning to attend from other parts of the country, I thought you may be interested in adding a VARA race on your calendar if it works out. 
The VARA High Desert Challenge takes place March 19 at Willow Springs, a very fast and fun circuit that will scare your pants off! (In a good way). 
April 23rd is the British Extravaganza at Buttonwillow. There is a feature race with all British cars. I know that these dates are not super close on the calendar to our Cup event but it may be a great scenario for some of our group and VARA would love to have us. They are looking into discount pricing for Cup racers. 

~Steve Belfer

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Dave <[email-masked]>
Date: Fri, 16 Oct 2015 13:27:14 -0700

Welcome back, Steve.
Thanks for posting this information.  
Also, HMSA usually holds an event at Laguna in March.
I'll check the Hooked on Driving schedule.  They regularly run events at Thunderhill.  
That would be another track worth visiting, if just for a track day.
There is always race cars testing in group C with open passing.  Thunderhill is a fast track and a favorite of many racers.
In any event, I think there will be a number options for us.

Dave H.

Sent from my iPad

> On Oct 16, 2015, at 10:59 AM, Steven Belfer <[email-masked]> wrote:
> 
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>