Subject: Re: [Fot] Attention Morgan Owners/Experts

From: Duncan Charlton <[email-masked]>
Date: Thu, 1 Oct 2015 19:12:54 -0500

Joe,
I’ll pass it along on the Morgan groups.
Duncan

> On Oct 1, 2015, at 11:19 AM, Joe Alexander <[email-masked]> wrote:
> 
> I have a brand new clutch cover/pressure plate.
> 
> It came off a TR4 Flywheel, but it has thrust "button" on the diaphragm fingers.
> 
> It occurs to me that it might be for a Morgan application.
> 
> Can anyone help? I can provide a picture.
> 
> Thanks,
> 
> Joe Alexander
> 645 1st Street
> Jesup, IA 50648
> The-vintage-racer.com
> Gasketinnovations.com
> Cell:  319.464.4711
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Joe Alexander <[email-masked]>
Date: Thu, 1 Oct 2015 20:27:40 -0500

It has a large graphite thrust bearing that one guy says is consistent with Morgan.

Another suggestion was that it was from an MGB.

Thanks,

Joe Alexander
645 1st Street
Jesup, IA 50648
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

> On Oct 1, 2015, at 7:12 PM, Duncan Charlton <[email-masked]> wrote:
> 
> Joe,