Subject: Re: [Fot] Rods

From: Joe Alexander <[email-masked]>
Date: Tue, 21 Jul 2015 16:25:43 -0500

We run billet crank with Chevy rods and typically shift at 5800 with Tilden Cam.

2:56 at Road America last fall
1:27 at Blackhawks Farms in June

This is with an interim stock TR3 head off of my 58 TR3A street car until we get around to changing to a well prepared head. Hopefully in a month or so.

Feels like a good combination for us.

Joe Alexander
645 1st Street
Jesup, IA 50648
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

> On Jul 21, 2015, at 3:22 PM, John Hasty <[email-masked]> wrote:
> 
> Chris, I should add,as Bob pointed out, we have a Moldex crank machined to accept the MANLY Ford rods in a 5 main pattern.  I try and shift @ 6200 which I don't consider "high" revs when one considers that the NASCAR guys turn upwards of 9000 with Ford motors.  I don't know the selection of bearing types for the P & C rods, but the selection for Ford rods is infinite, maybe another +.
> 
> Sent from my iPhone
> 
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Greg And Alison Blake <[email-masked]>
Date: Tue, 21 Jul 2015 19:39:23 -0600

Joe,

Ditto on the rotating assembly for the silver TR3. The infinite choices on rods and rod bearings was what ultimately convinced me to go that route.  

I shift at 6500, usually:)

Greg 

> On Jul 21, 2015, at 3:25 PM, Joe Alexander <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>