Subject: Re: [Fot] Spitfire Sighting I-25 between Pueblo and Colorado Springs. #3

From: Bud Rolofson <[email-masked]>
Date: Wed, 17 Jun 2015 19:30:40 -0600

That would be me with the #3 car. We got hailed out of the Sunday PM races by a huge thunderstorm and I was headed home early until a truck laid down 300 yards of hydraulic fluid in 3 lanes in the middle of Colorado Springs. Took an hour to get through that mess with Sunday traffic headed back to Denver.
Had great fun racing at Pueblo motor sports track that weekend with Jim Gray and our Triumph crew.
Bud

Sent from my Commodore 64

> On Jun 17, 2015, at 5:56 PM, Joe Alexander <[email-masked]> wrote:
> 
> FOT 
> 
> A member of FOT? Being pulled by Class C motor home headed north.
> 
> This was last Sunday during a huge back up of interstate traffic due to a very large accident. 
> 
> Regards,
> 
> Joe Alexander
> 645 1st Street
> Jesup, IA 50648
> The-vintage-racer.com
> Gasketinnovations.com
> Cell:  319.464.4711
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Joe Alexander <[email-masked]>
Date: Wed, 17 Jun 2015 20:38:15 -0500

Bud!

We were in the Silver Miata with the top down, when you dusted us off in the right hand lane with your motor home and trailer. We got off the next opportunity.

I knew it would be somebody familiar. This will be no surprise to Jan.

Joe Alexander
645 1st Street
Jesup, IA 50648
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

> On Jun 17, 2015, at 8:30 PM, Bud Rolofson <[email-masked]> wrote:
>