Subject: [Fot] Spitfire Sighting I-25 between Pueblo and Colorado Springs. #3

From: Joe Alexander <[email-masked]>
Date: Wed, 17 Jun 2015 18:56:19 -0500

FOT 

A member of FOT? Being pulled by Class C motor home headed north.

This was last Sunday during a huge back up of interstate traffic due to a very large accident. 

Regards,

Joe Alexander
645 1st Street
Jesup, IA 50648
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: "Jim Gray" <[email-masked]>
Date: Wed, 17 Jun 2015 19:03:09 -0600

Yes, that was our buddy Bud, # 3 black & silver. We were on our way back
from the race. We got rained out in the afternoon races. I was in the same
traffic jam.
Jim g

-----Original Message-----
From: Fot [mailto:[email-masked]] On Behalf Of Joe Alexander
Sent: Wednesday, June 17, 2015 5:56 PM
To: [email-masked]
Subject: [Fot] Spitfire Sighting I-25 between Pueblo and Colorado Springs.
#3

FOT 

This was last Sunday during a huge back up of interstate traffic due to a
very large accident. 

Regards,

Joe Alexander
645 1st Street
Jesup, IA 50648
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/fot/[email-masked]