Subject: [Fot] Southwick alloy front hubs - common bearing application ?

From: Randall via Fot <[email-masked]>
Date: Wed, 25 Mar 2015 12:36:01 -0700

I want to thank all who replied (in case I missed thanking anyone personally).

To recap for the group, there is no automotive application for these bearings, they are (expensive) industrial bearings.  Still
available (Summit Racing has them listed as well as many others) but not cheap.

Richard Good is now selling very similar aluminum alloy hubs, based on the same "uncle jack" design, but they have been slightly
modified to take a more common (and cheaper bearing).  His bearings won't fit the original Southwick hubs (unless perhaps the hubs
can be remachined to suit).

The good news is that I found the bag with the original bearings, hiding in a crate marked "TR Brake parts".

-- Randall  

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Tony Drews via Fot <[email-masked]>
Date: Wed, 25 Mar 2015 21:07:20 -0500

FYI - the new spec bearings are slightly larger diameter OD for the 
Cup (race) so it's conceivable that the old design hubs could be 
re-machined for the new bearings.  Last I knew, the newer bearings I 
selected when I did the re-design were half the cost or less than the 
original bearings but have the same load bearing capacity.  It could 
be that after re-machining the hub that the seal holding piece would 
no longer fit and new ones would need to be made.  Probably the outer 
edge could be knurled to get them to fit, the difference is only like 
0.010" in OD.

Nothing like the prospect of spending a couple of hundred in bearings 
to give new impetus to the search!  :)

Cheers, Tony Drews

At 02:36 PM 3/25/2015, Randall via Fot wrote:
>To recap for the group, there is no automotive application for these 
>bearings, they are (expensive) industrial bearings.  Still
>Richard Good is now selling very similar aluminum alloy hubs, based 
>on the same "uncle jack" design, but they have been slightly
>modified to take a more common (and cheaper bearing).  His bearings 
>won't fit the original Southwick hubs (unless perhaps the hubs
>The good news is that I found the bag with the original bearings, 
>hiding in a crate marked "TR Brake parts".
>
>-- Randall
>
>Donate: http://www.team.net/donate.html
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: 
>http://autox.team.net/mailman/options/fot/[email-masked]