Subject: [Fot] Bell Housing

From: John Hasty <[email-masked]>
Date: Wed, 10 Dec 2014 17:45:55 +0000

Are TR4 and TR6 housing the same?

John H. Hasty | MULLEN HOLLAND & COOPER P.A.
Attorney at Law
301 South York Street  (zip: 28052)
P.O. Box 488
Gastonia, NC 28053-0488
Telephone: 704.864.6751 | Facsimile: 704.861.8394
[email-masked]<http://@mhc-law.com> |
www.mhc-law.com<http://www.mhc-law.com/>
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: "Steve Yott" <[email-masked]>
Date: Wed, 10 Dec 2014 12:39:38 -0600

Shape and mounting points are the same.... construction changed (improved
over the years) with added strength.

Steve Yott