Subject: Re: [Fot] TR4 Differential Oil Seal

From: EDWARD BARNARD <[email-masked]>
Date: Tue, 14 Oct 2014 05:42:19 -0700

Mike:
I have not had a problem with any of the modern seals offered by the big three, but I almost always (95%) install a Speedi-Sleeve on the flange. This goes not only on diffs but also tranny outputs, front pulleys, and even some rear crank sealing surfaces. Even the newest of these items are now over thirty years old the grooves cut into them from previous seals are getting too big to ignore. 
I just finished a Mayflower diff that would have leaked just as bad as before if I hadn't insisted to the customer that it needed a sleeve. They gasp at the added expense ($45) but I wouldn't warranty it without the sleeve.
-Ed-  

On Tuesday, October 14, 2014 6:34 AM, Michael Moore <[email-masked]> wrote:

Is there a source out there to find a better quality seal for driveshaft
flange? Mine are leaking in my street and race car and have not been in that
long.

Thanks
Mike

62 TR4, Race car
63 TR4, Street car

Mike & Becky Moore
6050 Ruhl Road
Fairview, PA 16415

[demime 1.01d removed an attachment of type image/gif which had a name of image001.gif]
_______________________________________________
[email-masked]

http://www.fot-racing.com/

Archive: http://www.team.net/archive
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: fubog1 <[email-masked]>
Date: Tue, 14 Oct 2014 12:36:58 -0400

You will sometimes find that it is not the seal that's leaking, but the oil
getting by the splines and leaking out at the front of the flange around the
nut/washer; it's usually the seal though, or a grooved seal journal as Ed
points out.
Also make sure the RAX, housing is vented.
Glen
-----Original Message-----
From: Michael Moore <[email-masked]>
To: fot
<[email-masked]>
Sent: Tue, Oct 14, 2014 12:24 pm
Subject: [Fot] TR4
Differential Oil Seal

Is there a source out there to find a better quality
seal for driveshaft
flange? Mine are leaking in my street and race car and
have not been in that
long.

Thanks
Mike

62 TR4, Race car
63 TR4, Street car
Mike & Becky Moore
6050 Ruhl Road
Fairview, PA 16415

[demime 1.01d removed an
attachment of type image/gif which had a name of 
image001.gif]
_______________________________________________
[email-masked]
http://www.fot-racing.com

Archive:

---

From: "Robert M. Lang" <[email-masked]>
Date: Tue, 14 Oct 2014 13:18:10 -0400 (EDT)

Fugog writes:

WORD.

rml
---------------------------------------------------------------------------
Bob Lang              Triumph TR6!!            |  This space for rent
Former NER Solo Chair                          |
Voice:617-253-7438                             |  Cell: 339-927-4489
---------------------------------------------------------------------------
_______________________________________________
[email-masked]