Subject: [Fot] VSCDA - Road America

From: Allen Washatko <[email-masked]>
Date: Thu, 28 Aug 2014 22:41:45 -0500

FoT,

Who all is coming to this year's VSCDA ELVF at Road America?

Allen

Allen & Jody Washatko
1971 TR6  - Number 6
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Mike Jackson <[email-masked]>
Date: Fri, 29 Aug 2014 11:21:36 -0400 (GMT-04:00)

Definitely the steak place.  Truly in the middle of nowhere.  The only time I tried to go there without help of the BDI crowd I got lost!

You will often hear the likes of Danica Patrick and Nico Rosberg among others being called when their table is ready.

A real treat.

Wonder where Don Brick's TR4 is these days.  A true piece of history.  His driving was getting better every year right up until he chose to retire.

Mike Jackson 

-----Original Message-----
>From: Dean Tetterton <[email-masked]>
>Sent: Aug 29, 2014 9:25 AM
>To: Tony Drews <[email-masked]>
>Cc: Friends of Triumph <[email-masked]>
>Subject: Re: [Fot] VSCDA - Road America
>
>Tony
>         Hope you can carry on the tradition of the
>wine and cheese at Road America. My first meeting
>of the "gang" was at the MOTRHA event in 05. Got
>to see what Vintage Racing is all about. Enjoyed the
>great Blue Cheese by Don Brick and even got to
>go to the Steak place out in the middle of nowhere.
>Lots of fond memories of the week end.
>
>Dean T.
>
>
>On Aug 29, 2014, at 1:13 AM, Tony Drews wrote:
>
>> I'll be there.  Hoping to set up where Bob and Bill did at the entrance to
>the false grid, and also hoping to keep the wine and cheese tradition going.
>>
>> Tony Drews
>>
>> At 10:41 PM 8/28/2014, Allen Washatko wrote:
>>> FoT,
>>>
>Donate: http://www.team.net/donate.html
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Irv Korey <[email-masked]>
Date: Fri, 29 Aug 2014 11:21:57 -0500

On Fri, Aug 29, 2014 at 10:21 AM, Mike Jackson <[email-masked]>
wrote:

>
> Wonder where Don Brick's TR4 is these days.  A true piece of history.

The car is in the loving and capable hands of Ken Suhre, who resides on
central Illinois and is a FOT.

Irv Korey