Subject: Re: [Fot] Low oil pressure after overheating

From: [email-masked]
Date: Thu, 21 Aug 2014 01:45:55 +0000

Hi, glad to hear you are doing this in our area. Lots of questions there and possible problems/ scenarios. Lets start with the most obvious. The stock sized radiator will not work for a race car. You need not only the shrouding (which you need for sure) but you need more volume. There are cheap and expensive options. Start with a high quality oversized unit as big as you can fit and your over heating should stop. The right unit will fix your problem and last for decades. 
Jason Ostrowski
Friendly Ghost Racing
Sent via BlackBerry by AT&T

-----Original Message-----
From: [email-masked]
To: <[email-masked]>
Subject: [Fot] Low oil pressure after overheating

Hello,

I'm new to the group and hope I can get some advice.  My son and I are 
building a GT6 into a racer and need some help.  We've had the engine 
rebuilt with some mods.  Ross pistons, WBC cam, roller rockers, head 
shaved to approx. 10-1 compression, mild port job and balanced.

At Elkhart last weekend we overheated the engine and now there is no oil 
pressure at idle.  The engine runs strong, no noise, and still has 
pressure when cold.  As the engine warms the pressure drops.

I will add a heavier radiator cap and a shroud to direct air into the 
stock style (aluminum) radiator.  It's been suggested I shim the 
pressure relief valve to increase overall oil pressure.

Any advice on resolving the oil and temp problems.

The engine easily turns 6500 RPM's but we have the MSD set at 6000.  The 
engine has approx. 1000 miles on it.

Thanks,

Dave Amys
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Thu, 21 Aug 2014 01:48:31 +0000

Use a 17 lb radiator cap.
Jason Ostrowski
Friendly Ghost Racing
Sent via BlackBerry by AT&T

-----Original Message-----
From: [email-masked]
To: <[email-masked]>
Subject: [Fot] Low oil pressure after overheating

Hello,

Thanks,

Dave Amys

---

From: [email-masked]
Date: Thu, 21 Aug 2014 02:02:17 +0000

The cap should be farther up in the system than on the radiator, have it up as high as you can on an additional expansion tank where you fill the system from. And another overflow tank (as well) beyond that.
Jason Ostrowski
Friendly Ghost Racing
Sent via BlackBerry by AT&T

-----Original Message-----
From: [email-masked]
To: <[email-masked]>
Subject: [Fot] Low oil pressure after overheating

Hello,

Thanks,

Dave Amys

---

From: SCOTT JANZEN <[email-masked]>
Date: Wed, 20 Aug 2014 22:07:56 -0400

If it had good oil pressure before and doesn't now, I doubt it's the pressure
relief valve. Is there oil in the coolant or vice versa?   You said there is
no pressure at idle - is there pressure at higher RPMs?  You should of course
connect a pressure gauge to  the oil galley - remove one of the plugs on the
galley to do this - before you do anything else to make sure it's not the
gauge or connection.
I agree with Jason that you need a bigger or deeper rad, preferably aluminum
though obviously that won't cure the oil pressure issue.
Keep us posted.  Good luck!

Sent from my mobile device

> On Aug 20, 2014, at 9:30 PM, [email-masked] wrote:
>
> Hello,
>
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Christian Marx <[email-masked]>
Date: Thu, 21 Aug 2014 11:53:54 +0200

Hi,

I suppose you have dirt in your relief valve.

Cheers
Chris
Am 21.08.2014 03:30 schrieb <[email-masked]>:

> http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "Marcel Van Mulders" <[email-masked]>
Date: Fri, 22 Aug 2014 19:32:09 +0200

Putting shims behind the spring in the pressure relief valve will increase
the oil pressure when the engine is cold, but it won't have any influence
when the engine is hot, because the pressure relief valve is fully closed
when the oil has warmed up (unless it is leaking...) Without a pressure
relief valve, the oil pressure could be very very high when starting the
engine from cold. This valve is there only to prevent damage.
If the gauge needle is no longer moving at idle after warming up, it's
likely that something has happened since the overheating. The gauge can be
at fault. If not,checking the oil pump and bearings is not that much work.
It would be a pity to ruin a freshly rebuilt engine, it seems the engine has
not a lot of damage now.
Marcel
-----Oorspronkelijk bericht-----
Van: Fot [mailto:[email-masked]] Namens [email-masked]
Verzonden: donderdag 21 augustus 2014 3:30
Aan: [email-masked]
Onderwerp: [Fot] Low oil pressure after overheating

Hello,

I'm new to the group and hope I can get some advice.  My son and I are
building a GT6 into a racer and need some help.  We've had the engine
rebuilt with some mods.  Ross pistons, WBC cam, roller rockers, head shaved
to approx. 10-1 compression, mild port job and balanced.

At Elkhart last weekend we overheated the engine and now there is no oil
pressure at idle.  The engine runs strong, no noise, and still has pressure
when cold.  As the engine warms the pressure drops.

I will add a heavier radiator cap and a shroud to direct air into the stock
style (aluminum) radiator.  It's been suggested I shim the pressure relief
valve to increase overall oil pressure.

Thanks,

Dave Amys

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Tony Drews <[email-masked]>
Date: Fri, 22 Aug 2014 12:50:53 -0500

I've been thinking about this one.  Nothing about overheating SHOULD 
cause the oil pressure change unless you managed to get water into 
the oil, I'd think.  I'd start with removing and cleaning the oil 
pressure relief valve in the oil filter head.  If you get a piece of 
dirt holding that open, you'll see low pressure at idle.

Of course the advice about "check the pressure gauge" is good too.

Tony Drews

At 08:30 PM 8/20/2014, [email-masked] wrote:
>http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Tony and Annie Garmey <[email-masked]>
Date: Fri, 22 Aug 2014 10:59:51 -0700

You say overheat ! How hot ? First thing I'd do is look inside the  oil
filter.

Sent from my iPhone

> On Aug 22, 2014, at 10:51 AM, "Tony Drews" <[email-masked]> wrote:
>
> I've been thinking about this one.  Nothing about overheating SHOULD cause
the oil pressure change unless you managed to get water into the oil, I'd
think.  I'd start with removing and cleaning the oil pressure relief valve in
the oil filter head.  If you get a piece of dirt holding that open, you'll see
low pressure at idle.
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Jason Ostrowski <[email-masked]>
Date: Fri, 22 Aug 2014 14:17:43 -0500

While we are on the subject of cutting open the oil filter;
A quick comment on this:
(only because I have seen 2 people recently not look not far enough towards
the center of the filter)
The bad stuff (if it exists) is not seen until you go deep into the inner
folds of the filter.
Hope you see nothing.
Jason Ostrowski
Friendly Ghost Racing

On Fri, Aug 22, 2014 at 12:59 PM, Tony and Annie Garmey <
[email-masked]> wrote:

> cause
> http://autox.team.net/mailman/options/fot/[email-masked]

---

From: fubog1 <[email-masked]>
Date: Fri, 22 Aug 2014 16:33:15 -0400 (EDT)

I love my Obergs but I still cut open a lot of filters.
(There is a nice
"tubing cutter" type tool for removing the end.)
Once the element is out,
discard the junk ie spring, inner screen, & bypass valve, then the cardboard
ends have to be removed. Once the ends are removed and the end of the pleats
are open and not full of sealant gook, slice it and unfold, dirty side (outer)
up, on paper towels (weight the ends down so it lays out flat). For best
results, walk away for 24 hours and then check it.The paper towel part is
important because it pulls the oil out of the element, and any trash is
apparent in the inner crease of the folds. 
Glen.

-----Original
Message-----
From: Jason Ostrowski <[email-masked]>
To: Tony and Annie
Garmey <[email-masked]>
Cc: fot <[email-masked]>
Sent: Fri, Aug 22,
2014 3:54 pm
Subject: Re: [Fot] Low oil pressure after overheating

While we
are on the subject of cutting open the oil filter;
A quick comment on this:
(only because I have seen 2 people recently not look not far enough towards
the center of the filter)
The bad stuff (if it exists) is not seen until you
go deep into the inner
folds of the filter.
Hope you see nothing.
Jason
Ostrowski
Friendly Ghost Racing

On Fri, Aug 22, 2014 at 12:59 PM, Tony and
Annie Garmey <
[email-masked]> wrote:

> You say overheat ! How hot ?
First thing I'd do is look inside the  oil
cause
> think.  I'd start with removing and cleaning the oil pressure relief
valve
> in
> the oil filter head.  If you get a piece of dirt holding that
open, you'll
> see
> >> I'm new to the group
and hope I can get some advice.  My son and I are
> >> building a GT6 into a
racer and need some help.  We've had the engine
> >> rebuilt with some mods.
Ross pistons, WBC cam, roller rockers, head
> >> shaved to approx. 10-1
compression, mild port job and balanced.
> >>
> >> At Elkhart last weekend we
overheated the engine and now there is no oil
> >> pressure at idle.  The
engine runs strong, no noise, and still has
> >> Dave
Amys
[email-masked]
> >> Donate:

Archive:

---

From: [email-masked]
Date: Fri, 22 Aug 2014 21:07:34 +0000 (UTC)

Since this thread drifted into oil filter inspections I though I'd mention K &
P oil filters. ( no financial interest )

http://kandpengineering.com/

They are billet aluminum with removable/cleanable filter elements and they are
FAA approved. I put in a clean filter element

on Saturdays and again before the next race. They are also really handy when
breaking motors in.

just though I'd throw that out there, I haven't bought or cut open an oil
filter in two years.

jim g

B 

----- Original Message -----

From: "Ostrowski, Jason" <[email-masked]>
To: "Tony and Annie" <[email-masked]>
Cc: "fot" <[email-masked]>
Sent: Friday, August 22, 2014 1:17:43 PM
Subject: Re: [Fot] Low oil pressure after overheating

On Fri, Aug 22, 2014 at 12:59 PM, Tony and Annie Garmey <
[email-masked]> wrote:

> You say overheat ! How hot ? First thing I'd do is look inside the B oil
> filter.
>
> Sent from my iPhone
>
> > I've been thinking about this one. B Nothing about overheating SHOULD
> cause
> think. B I'd start with removing and cleaning the oil pressure relief valve
> in
> the oil filter head. B If you get a piece of dirt holding that open, you'll
> see
> low pressure at idle.
> >
> >> I'm new to the group and hope I can get some advice. B My son and I are
> >> building a GT6 into a racer and need some help. B We've had the engine
> >> rebuilt with some mods. B Ross pistons, WBC cam, roller rockers, head
> >> pressure at idle. B The engine runs strong, no noise, and still has
> >> pressure when cold. B As the engine warms the pressure drops.
> >>
> >> stock style (aluminum) radiator. B It's been suggested I shim the
> >> The engine easily turns 6500 RPM's but we have the MSD set at 6000. B The

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Vangoughv <[email-masked]>
Date: Fri, 22 Aug 2014 18:42:37 -0400

What type and viscosity motor oil are you using?
Newer Alloy style oil pump or a re-cored original cast type?

Vince

> On Aug 22, 2014, at 1:50 PM, Tony Drews <[email-masked]> wrote:
>
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: [email-masked]
Date: Fri, 22 Aug 2014 22:56:59 +0000

Vince, for the GT6... FGR runs only redline straight 50wt racing synthethic In all our race cars. We have been using this for years. Expensive yes! But don't argue with years of success in GT6 race motors. Zippy has run on this for many, many, years. In my opinion there is no substitute. 
Nfi,
Jason Ostrowski
Friendly Ghost Racing
Sent via BlackBerry by AT&T

-----Original Message-----
From: Vangoughv <[email-masked]>
To: Tony Drews<[email-masked]>
Cc: [email-masked]<[email-masked]>
Subject: Re: [Fot] Low oil pressure after overheating

Vince

---

From: Edward Dunn <[email-masked]>
Date: Mon, 25 Aug 2014 11:48:18 -0700

Jason, what kind of typical life (hours, etc.)are you getting on your GT6
motor?

Ed Dunn

-----Original Message-----
From: Fot [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Friday, August 22, 2014 3:57 PM
To: Vangoughv; Fot; Tony Drews
Cc: Fot
Subject: Re: [Fot] Low oil pressure after overheating

Vince, for the GT6... FGR runs only redline straight 50wt racing synthethic In
all our race cars. We have been using this for years. Expensive yes! But don't
argue with years of success in GT6 race motors. Zippy has run on this for
many, many, years. In my opinion there is no substitute.
Nfi,
Jason Ostrowski
Friendly Ghost Racing
Sent via BlackBerry by AT&T

-----Original Message-----
From: Vangoughv <[email-masked]>
To: Tony Drews<[email-masked]>
Cc: [email-masked]<[email-masked]>
Subject: Re: [Fot] Low oil pressure after overheating

Vince

>> I'm new to the group and hope I can get some advice.  My son and I
>> are building a GT6 into a racer and need some help.  We've had the
>> engine rebuilt with some mods.  Ross pistons, WBC cam, roller
>> rockers, head shaved to approx. 10-1 compression, mild port job and
balanced.
>>
>> At Elkhart last weekend we overheated the engine and now there is no
>> oil pressure at idle.  The engine runs strong, no noise, and still
>> has pressure when cold.  As the engine warms the pressure drops.
>>
>> The engine easily turns 6500 RPM's but we have the MSD set at 6000.
>> The engine has approx. 1000 miles on it.
>>
>> Thanks,
>>
>> Dave Amys

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: [email-masked]
Date: Mon, 25 Aug 2014 23:59:09 +0000

Before I answer that, let me explain why I believe we have very good motor life. Without getting too philosphical, FGR has a very simple (fanatically deliberate and careful) way of preparing the cars. 
That is to say, I'd have to admit that I cannot really even take credit for most of it. Rather, I am very lucky to have just studied the Factory Manual, Kas' words and writtings; and mostly just collected race info, cars, and parts... while surrounding myself with best racing GT6's for my whole life. 
For the most part I think of myself as a curator. I thank John Reed, my dad, Dennis Moeller, and anyone that ever touched the yellow car... Because these guys gave me the templates for success in the small world of GT6 racing.
That is NOT to say that I just leave the cars as they sit. 
What I try to do (first and foremost) is make absolutly sure that they are prepared to the last Benchmark of success before every time I take one out. Since I started racing the cars, I have been doing just that, and get faster and faster every time I get in to drive.
40 years ago, when I was just a baby pup my "Family" started racing GT6's in showroom stock. The cars were pretty much STOCK. My Dad and John drove the friggin wheels off them. (My dad's car has been brought back to this original showroom stock configuration.) The other 2 cars, some 44 years later; have evoled into what they are today... essentially true and period correct D production demons with each their own cheats and tweeks. Lots of custom upgrades of parts or systems that failed as well as lots of original and well-maintained GT6 parts. Between the 3 race cars in the stable we have documents for over 400 race weekends. And yes, we have had some big fails and big fixes. We have struggled in certain areas but that often speaks to budgets rather than balls.
In all those races, one fist remains closed when I start counting motor failures. We simply don't have them. 

To answer your question, our super trick motor (AND 1972 SCCA spec legal in every way; lovingly developed by John Reed) is on a SIX race weekend "rebuild to spec/freshen-up" cycle. 
The yellow car... You won't believe this; I retired this motor last weekend after it's 20th weekend of racing! I just felt that the time had come. 
So the spare motor (Prepared to the LAST KNOWN BENCHMARK SUCCESS) will go in next next while we freshen it up)
I figure the difference in cam and gearing define the parameters of longevity. The gearing and cam in the yellow car will peak perforance at about 7000rpm and Zippy will rev past 8000 any time you have the balls to take it there.
ALL the motors have STOCK cranks, STOCK rods (lightened and race preped in every way), venolia pistons, 2 carbs (stockish...he, he) and a shortly shaved head that delivers about 12.75 to 1. Roller rockers=NO. 
To be frank, Most of what has been happening with blown GT6 race motors has happened only because of lack of proper attention to details accertained by working within the parameters of  an existing LAST KNOWN BENCHMARK OF SUCCESS.    
If you are beaten by a GT6 motor, your motor has not been set to this specification.
Jason Ostrowski
Friendly Ghost Racing
"Balls out GT6 race car museum" Curator:
"SB" 1968 Triumph GT6 #72
"Captain Dirt" 1969 DP Triumph GT6+ #27 
"Zippy" 1969 DP Triumph GT6+ #69
Sent via BlackBerry by AT&T

-----Original Message-----
From: Edward Dunn <[email-masked]>
Date: Mon, 25 Aug 2014 11:48:18 
To: [email-masked]<[email-masked]>
Cc: Fot<[email-masked]>
Subject: RE: [Fot] Low oil pressure after overheating

Jason, what kind of typical life (hours, etc.)are you getting on your GT6 motor?

Ed Dunn

-----Original Message-----
From: Vangoughv <[email-masked]>
To: Tony Drews<[email-masked]>
Cc: [email-masked]<[email-masked]>
Subject: Re: [Fot] Low oil pressure after overheating

Vince

> I've been thinking about this one.  Nothing about overheating SHOULD
the oil pressure change unless you managed to get water into the oil, I'd think.  I'd start with removing and cleaning the oil pressure relief valve in the oil filter head.  If you get a piece of dirt holding that open, you'll see low pressure at idle.
>> rockers, head shaved to approx. 10-1 compression, mild port job and balanced.
>>