Subject: Re: [Fot] Russ Moore Email

From: Tony Drews <[email-masked]>
Date: Wed, 30 Jul 2014 12:27:35 -0500

Russ Moore: "Spitfire Racing" <[email-masked]>

Tony

At 11:57 AM 7/30/2014, Joseph Lesnowski wrote:
>Hi Group,
>     Recently tried to send Russ an email and had it returned.
>Anyone have a current address for Russ?
>
>Joe L.
>_______________________________________________
>[email-masked]
>
>http://www.fot-racing.com
>
>Donate: http://www.team.net/donate.html
>Archive: http://www.team.net/archive
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: 
>http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: "Spitfire Racing" <[email-masked]>
Date: Wed, 30 Jul 2014 16:55:26 -0400

There's an underscore between Spitfire and Racing which doesn't show well in
a hyperlink.

Russ

-----Original Message-----
From: Fot [mailto:[email-masked]] On Behalf Of Tony Drews
Sent: Wednesday, July 30, 2014 1:28 PM
To: Joseph Lesnowski; [email-masked]
Subject: Re: [Fot] Russ Moore Email

Tony

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]