Subject: [Fot] SU Rebuilder

From: Todd Redmond <[email-masked]>
Date: Mon, 11 Nov 2013 15:46:07 -0500 (EST)

FoT,

Just finished my first tractor engine build. I'll post a pic on the FoT
Facebook page.

Looking for someone to rebuild the SU's. B Who is B recommended? B British
Classic Motors are away until end of February. B I could wait until then.
B Was just checking on others.

Thanks

Todd Redmond
TS #29341
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: davehogye <[email-masked]>
Date: Tue, 12 Nov 2013 04:00:40 +0000 (UTC)

Joe Curto did my carbs and missed a couple things. I had meticulously cleaned 3 disassembled carbs and sent them to Joe to build a set with the best parts between them. 
While tuning I found that the dampers didn't match, one had a long shaft and one short. I also found that one of the pistons was machined to a larger diameter where the damper fits and one of the carbs, after about 300 miles of use, started to leak fuel from the main jet seal. 
The problem might be that Joe doesn't actually do the work, but I'm not sure about that. In any event, details were missed. Oh, Joe did send a nice SU coffee mug with the carbs, but unfortunately it was poorly packaged and the handle was broken off during shipping. 

I had communicated with Paltech before I send mine to Curto. They sure seemed to be on their game and detail oriented. Their polishing is unique. Their price is, if I remember correctly, less than Curto, but not by much. Both are very reasonably priced and about half to 1/3rd the cost of a new set of SUs, depending on HS6s or H6s. The difference in price was probably about the cost of a coffee mug. 

I checked Ray Marty's website and I think it's a fair bet that Ray will actually be doing the work and to a quality level. One photo on his website shows him milling the carb to manifold gasket surface... Really? The photos remind me of a very detail oriented, shall I say completely annal retentive machinist friend of mine. 

Dave H. 

----- Original Message -----
From: "Todd Redmond" <[email-masked]> 
To: "[email-masked] [email-masked]" <[email-masked]> 
Sent: Monday, November 11, 2013 12:46:07 PM 
Subject: [Fot] SU Rebuilder 

FoT, 

Thanks 

Todd Redmond 
TS #29341

---

From: <[email-masked]>
Date: Tue, 12 Nov 2013 6:30:24 -0500

hmmmm, I've had nothing but first class work from Joe, racing and street, for the past 30 years. For me I would rather pass on the polishing metal and buy additional jets instead.

---- davehogye <[email-masked]> wrote: 
> Donate: http://www.team.net/donate.html 
> Forums: http://www.team.net/forums 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked] 
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: The Fooddude <[email-masked]>
Date: Mon, 11 Nov 2013 16:57:20 -0600

Dana at sucarbs.com

Sent via and typos courtesy wireless handheld device.

-------- Original message --------
From: Jim Norlin <[email-masked]> 
Date: 11/11/2013  4:11 PM  (GMT-06:00) 
To: [email-masked] 
Subject: Re: [Fot] SU Rebuilder 
 
I had Ray Marty, rebuild mine a couple of years ago and I'm very happy 
with the results.

http://www.martyenterprisesoforegon.com/

Jim

On 11/11/2013 12:46 PM, Todd Redmond wrote:
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/fot/[email-masked]