Subject: Re: [Fot] 1147 Spitfire Exhaust Valves

From: "Charly Mitchel" <[email-masked]>
Date: Mon, 4 Nov 2013 09:55:22 -0800

Have you tried here?
http://www.bpnorthwest.com/triumph/spitfire/engine-cylinder-head/valves-and-springs-1147.html

Charly

TR6 #44
----- Original Message ----- 
From: "Robert MacKenzie" <[email-masked]>
To: "''Friends of Triumph' Triumph'" <[email-masked]>
Sent: Monday, November 04, 2013 7:56 AM
Subject: [Fot] 1147 Spitfire Exhaust Valves

>I have a 1147 head with two bent valves.
>
> Length: 4.250 inch
> Diameter: 1.219
> Tip Length: 0.235 inch - single round grove
> 6mm stem diameter
>
> Do anybody know a source for these valves?
>
> Thanx
>
> Robert MacKenzie
> _______________________________________________
> [email-masked]
>
> http://www.fot-racing.com
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Duane Bailey <[email-masked]>
Date: Mon, 4 Nov 2013 11:20:44 -0800 (PST)

Sounds like the Mitsubishi valves that I have been running. Stock would have 5/16 stems.
I was buying them from Rick Cline
Duane

________________________________
From: Charly Mitchel <[email-masked]>
To: Robert MacKenzie <[email-masked]>; ''Friends of Triumph' Triumph' <[email-masked]> 
Sent: Monday, November 4, 2013 12:55 PM
Subject: Re: [Fot] 1147 Spitfire Exhaust Valves

Have you tried here?

Charly

TR6 #44
----- Original Message ----- 
From: "Robert MacKenzie" <[email-masked]>
To: "''Friends of Triumph' Triumph'" <[email-masked]>
Sent: Monday, November 04, 2013 7:56 AM
Subject: [Fot] 1147 Spitfire Exhaust Valves

> http://www.fot-racing.com/
>

http://www.fot-racing.com/