Subject: [Fot] A-Type O/D Conversion Shift Tower Issue

From: Glenn Franco <[email-masked]>
Date: Sun, 17 Nov 2013 17:10:27 -0500

Hi All

I'm converting an early TR6 Trans to Overdrive.
The issue I'm having is drilling and tapping the shift tower for the 
lock out switches.
The installed back up lamp switch has a thread pitch of 2mm per my 
thread gauge and the O.D. is just shy of 16 mm.
I'm assuming a 16mm x 2 tap. Is this correct?

The second issue I'm having is the oil pump plunger refuses to come out 
of the housing.
The eccentric on the output shaft was completely worn out. I'm guessing 
there's an issue there.
Any suggestions for removal?

Thanks in advance
Glenn
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: "Steve Yott" <[email-masked]>
Date: Sun, 17 Nov 2013 16:23:31 -0600

Glen,
Correct, the new switches are metric and use a 16mm x2 thread.  The older
switches use a 5/8-11 imperial thread.  On the oil pump are you working with
an "A" or "J" type?

Steve Yott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Glenn Franco
Sent: Sunday, November 17, 2013 4:10 PM
To: Friends of triumph; [email-masked]
Subject: [Fot] A-Type O/D Conversion Shift Tower Issue

Hi All

I'm converting an early TR6 Trans to Overdrive.
The issue I'm having is drilling and tapping the shift tower for the lock
out switches.
The installed back up lamp switch has a thread pitch of 2mm per my thread
gauge and the O.D. is just shy of 16 mm.
I'm assuming a 16mm x 2 tap. Is this correct?

The second issue I'm having is the oil pump plunger refuses to come out of
the housing.
The eccentric on the output shaft was completely worn out. I'm guessing
there's an issue there.
Any suggestions for removal?

Thanks in advance
Glenn

---

From: Randall <[email-masked]>
Date: Mon, 18 Nov 2013 23:38:30 +0000

> Any suggestions for removal?

Make certain you remove the check valve in the side first !

Here's my version of the process that Larry & Sam (& Nelson) wrote up:

http://tinyurl.com/oy38gvh

Once the body was touching the piece of steel, I added a big socket as a spacer and pulled some more.  Takes quite a bit of force, but it will move.  If you wanted you could probably heat the housing up and make it pull easier.

Randall