Subject: Re: [Fot] 1" x 23 spline clutch disk?

From: John Hasty <[email-masked]>
Date: Tue, 19 Nov 2013 21:34:39 -0500

TR7. That's what we use.  Spec has the clutch.

Sent from my iPhone

On Nov 19, 2013, at 8:17 PM, Tony Drews <[email-masked]> wrote:

> Looks like I'm converting to the Quaife dog gears.  Merry Christmas to me!
Anyway, this arrangement uses a 1" x 23 spline clutch disk.  Anyone know what
car I'd order that out of?  I'm running a stock type pressure plate...
>
> Thanks, Tony Drews
> _______________________________________________
> [email-masked]
>
> http://www.fot-racing.com
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Mark J Bradakis <[email-masked]>
Date: Tue, 19 Nov 2013 19:39:55 -0700

> TR7. That's what we use.  Spec has the clutch.

Also later Spitfires with the single rail box, as I recall.

mjb.