Subject: Re: [Fot] SU Rebuilder

From: Scott Janzen <[email-masked]>
Date: Mon, 11 Nov 2013 16:04:46 -0500

Joe Curto

On Nov 11, 2013, at 3:46 PM, Todd Redmond wrote:

FoT,

Just finished my first tractor engine build. I'll post a pic on the FoT
Facebook page.

Looking for someone to rebuild the SU's. B Who is B recommended? B British
Classic Motors are away until end of February. B I could wait until then.
B Was just checking on others.

Thanks

Todd Redmond
TS #29341
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: John Hasty <[email-masked]>
Date: Mon, 11 Nov 2013 16:11:39 -0500

Ditto

Sent from my iPhone

On Nov 11, 2013, at 4:04 PM, Scott Janzen <[email-masked]> wrote:

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/fot/[email-masked]
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Sam Halkias <[email-masked]>
Date: Mon, 11 Nov 2013 16:53:09 -0500

I strongly recommend Paltech. Check them out @

http://www.paltech1.com/id4.html

He also does micro polishing, your carbs will look better than new!

Sam Halkias

> From: [email-masked]
> Date: Mon, 11 Nov 2013 16:11:39 -0500
> To: [email-masked]
> CC: [email-masked]
> Subject: Re: [Fot] SU Rebuilder
>
> Ditto
>
> Sent from my iPhone
>
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Jim Norlin <[email-masked]>
Date: Mon, 11 Nov 2013 14:11:39 -0800

I had Ray Marty, rebuild mine a couple of years ago and I'm very happy 
with the results.

http://www.martyenterprisesoforegon.com/

Jim

On 11/11/2013 12:46 PM, Todd Redmond wrote:
> http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Sam Halkias <[email-masked]>
Date: Mon, 11 Nov 2013 23:23:07 -0500

And Paltech also does a wonderful Hitachi SU conversion for TR's! He even
handles Webers. All of his work comes out looking and working better than new.
I have used him for two years and probably have had over a dozen sets of carbs
and conversions done with zero problems.

Sam

> Date: Tue, 12 Nov 2013 04:00:40 +0000
> From: [email-masked]
> To: [email-masked]
> CC: [email-masked]
> Joe Curto did my carbs and missed a couple things. I had meticulously
cleaned 3 disassembled carbs and sent them to Joe to build a set with the best
parts between them.
> While tuning I found that the dampers didn't match, one had a long shaft and
one short. I also found that one of the pistons was machined to a larger
diameter where the damper fits and one of the carbs, after about 300 miles of
use, started to leak fuel from the main jet seal.
> The problem might be that Joe doesn't actually do the work, but I'm not sure
about that. In any event, details were missed. Oh, Joe did send a nice SU
coffee mug with the carbs, but unfortunately it was poorly packaged and the
handle was broken off during shipping.
>
>
> I had communicated with Paltech before I send mine to Curto. They sure
seemed to be on their game and detail oriented. Their polishing is unique.
Their price is, if I remember correctly, less than Curto, but not by much.
Both are very reasonably priced and about half to 1/3rd the cost of a new set
of SUs, depending on HS6s or H6s. The difference in price was probably about
the cost of a coffee mug.
>
>
> I checked Ray Marty's website and I think it's a fair bet that Ray will
actually be doing the work and to a quality level. One photo on his website
shows him milling the carb to manifold gasket surface... Really? The photos
remind me of a very detail oriented, shall I say completely annal retentive
machinist friend of mine.
>
>
> Dave H.
>
>
>
>
>
>
>
> ----- Original Message -----
> From: "Todd Redmond" <[email-masked]>
> To: "[email-masked] [email-masked]" <[email-masked]>
> Sent: Monday, November 11, 2013 12:46:07 PM
> Subject: [Fot] SU Rebuilder
>
> FoT,
>
>
http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Duncan Charlton <[email-masked]>
Date: Tue, 12 Nov 2013 07:41:49 -0600

Joe Curto knows what he's doing.
Duncan
1952 Morgan Plus 4 red #6

On Monday, November 11, 2013, Todd Redmond wrote:

> Unsubscribe/Manage: http://autox.team.net/mailman/
> options/fot/[email-masked]

---

From: "Bill Tobin" <[email-masked]>
Date: Tue, 12 Nov 2013 08:35:24 -0500

I put a set of Paltech's carbs on my car last spring and they work very 
well. Cost was reasonable. His work is like Richard Good's: Excellent!
NFI
Bill----- Original Message ----- 
From: "Sam Halkias" <[email-masked]>
To: "davehogye" <[email-masked]>; "Todd Redmond" 
<[email-masked]>
Cc: <[email-masked]>
Sent: Monday, November 11, 2013 11:23 PM
Subject: Re: [Fot] SU Rebuilder

> http://autox.team.net/mailman/options/fot/[email-masked]

---

From: [email-masked]
Date: Tue, 12 Nov 2013 12:26:06 -0500 (EST)

I've used SUCARBS.COM--Dana Britton and was very satisfied. They are in
Wichita, Ks.
                                             Jim TR4 #223

-----Original Message-----
From: Todd Redmond <[email-masked]>
To: [email-masked] [email-masked] <[email-masked]>
Sent: Mon, Nov 11, 2013 1:51 pm
Subject: [Fot] SU Rebuilder

FoT,

Thanks

Todd Redmond
TS #29341

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Jim Norlin <[email-masked]>
Date: Tue, 12 Nov 2013 11:20:42 -0800

Dave - You nailed it with respect to Ray Marty.  He's the only one in 
his shop and he is detail oriented.  You will get back all the parts he 
replaced along with a detailed list of the repairs he made and what he 
found was wrong.  I've also had Ray rebuild my GT6 gearbox.

Jim

On 11/11/2013 8:00 PM, davehogye wrote:
> Joe Curto did my carbs and missed a couple things. I had meticulously cleaned 3 disassembled carbs and sent them to Joe to build a set with the best parts between them.
> While tuning I found that the dampers didn't match, one had a long shaft and one short. I also found that one of the pistons was machined to a larger diameter where the damper fits and one of the carbs, after about 300 miles of use, started to leak fuel from the main jet seal.
> The problem might be that Joe doesn't actually do the work, but I'm not sure about that. In any event, details were missed. Oh, Joe did send a nice SU coffee mug with the carbs, but unfortunately it was poorly packaged and the handle was broken off during shipping.
>
>
> I had communicated with Paltech before I send mine to Curto. They sure seemed to be on their game and detail oriented. Their polishing is unique. Their price is, if I remember correctly, less than Curto, but not by much. Both are very reasonably priced and about half to 1/3rd the cost of a new set of SUs, depending on HS6s or H6s. The difference in price was probably about the cost of a coffee mug.
>
>
> I checked Ray Marty's website and I think it's a fair bet that Ray will actually be doing the work and to a quality level. One photo on his website shows him milling the carb to manifold gasket surface... Really? The photos remind me of a very detail oriented, shall I say completely annal retentive machinist friend of mine.
>
>
> Dave H.
>
>
>
>
>
>
>
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]