Subject: [Fot] TR3 rear shock linkage arm bushing

From: [email-masked]
Date: Thu, 17 Oct 2013 13:53:55 -0400 (EDT)

Who can supply a new racing-quality bushing for the TR3 rear lever  shock 
arm?
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: steve <[email-masked]>
Date: Thu, 17 Oct 2013 16:28:02 -0700 (GMT-07:00)

Those are a real pain to remove and re-fit, especially on my car where there are some other parts in the way. The tapered shaft really got stuck and wouldn't come out easily. Last time I rebuilt my rear lever shocks, I had a new set of "bushings" made up with heim joints, a shaft, and some small spacers.  I believe the heim-joints are each a different size hole so it's a bit of a pain but fairly easy to make up.  Also, it's effortless to install or remove.

~Steve

-----Original Message-----
>From: [email-masked]
>Sent: Oct 17, 2013 10:53 AM
>To: [email-masked]
>Subject: [Fot] TR3 rear shock linkage arm bushing
>
>Donate: http://www.team.net/donate.html
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: John Styduhar <[email-masked]>
Date: Sun, 20 Oct 2013 17:50:27 -0400

I like the idea of an adjustable rear shock link for the solid axle rear
end.  I'm finding that the shock lever arm will bottom out before the axle
is perched on the frame.

On Thu, Oct 17, 2013 at 7:28 PM, steve <[email-masked]> wrote:

> Those are a real pain to remove and re-fit, especially on my car where
> there are some other parts in the way. The tapered shaft really got stuck
> and wouldn't come out easily. Last time I rebuilt my rear lever shocks, I
> had a new set of "bushings" made up with heim joints, a shaft, and some
> small spacers.  I believe the heim-joints are each a different size hole so
> it's a bit of a pain but fairly easy to make up.  Also, it's effortless to
> install or remove.
>
> ~Steve
>
> >Unsubscribe/Manage:
> http://autox.team.net/mailman/options/fot/[email-masked]
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/fot/[email-masked]