Subject: [Fot] TR8 steering rack

From: Shawn Frank <[email-masked]>
Date: Thu, 17 Oct 2013 11:04:26 -0700 (PDT)

I am looking for a steering rack for a 1980 TR8. Does anyone have experience with a good replacement rack?

Thank you in advance...

Shawn Frank
Spitfire & GT6 Magazine-Editor
Continued Legacy-Owner
Friends of Triumph/NASS/BCCI
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: "Jack Brooks" <[email-masked]>
Date: Sun, 20 Oct 2013 16:52:26 -0700

Frank,

Check the wedge list.  There is a standard GM box which, with the TR8's
cover is a perfect swap candidate.

Jack, away and unable to provide the full data

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Shawn Frank
Sent: Thursday, October 17, 2013 11:04 AM
To: Friends of Triumph
Subject: [Fot] TR8 steering rack

I am looking for a steering rack for a 1980 TR8. Does anyone have experience
with a good replacement rack?

Thank you in advance...

Shawn Frank