Subject: Re: [Fot] Floor pans

From: "Robert M. Lang" <[email-masked]>
Date: Fri, 4 Oct 2013 08:25:35 -0400 (EDT)

The URL for this company is:

c2cfabrication.com

I have no direct experience with them (that I know of).

Part of me wonders if they picked up the tooling from one of the body 
panel fabricators from "back in the day". The names escape me, but I used 
to have a couple of catalogs back in the 80's from at least a couple of 
companies that made panels and partial panels for pretty much everything.

In any case, the web site looks promising.

Regards,
rml

p.s. nice job getting your car BACK ON TRACK at ELVF! That was pretty kool 
IMHO. 
---------------------------------------------------------------------------
Bob Lang              Triumph TR6!!            |  This space for rent
Former NER Solo Chair                          |
Voice:617-253-7438                             |  Cell: 339-927-4489
---------------------------------------------------------------------------
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Fri, 4 Oct 2013 09:00:35 -0400

Sounds like the pans may be of poor quality so you get what you pay for again.
Found the website when looking for a frame for my TR4  good to know first hand
from FoT members

Sent from my iPhone

On 2013-10-04, at 8:25 AM, "Robert M. Lang" <[email-masked]> wrote:

> Part of me wonders if they picked up the tooling from one of the body panel
fabricators from "back in the day". The names escape me, but I used to have a
couple of catalogs back in the 80's from at least a couple of companies that
made panels and partial panels for pretty much everything.
IMHO.

---

From: Glenn Franco <[email-masked]>
Date: Fri, 04 Oct 2013 09:13:15 -0400

I contacted the owner of this company directly last year. They are a 
local company near Detroit, Mi
The floor pans are soft tooled (Big 3 engineering term for temp tools).
The floor pans are not comparable to the British Motor Heritage floor 
pans available from the British Parts Suppliers.
If you have the body off, I would not recommend these as they do not 
have the ~3" downstanding flange that connects to the lower rocker.
There are also no holes or weld nuts for the tunnel.
I would consider this a patch panel to drop in rather than a factory 
repair part.
FYI
Glenn

On 10/4/2013 8:25 AM, Robert M. Lang wrote:
> panel fabricators from "back in the day". The names escape me, but I 
> used to have a couple of catalogs back in the 80's from at least a 
> couple of companies that made panels and partial panels for pretty 
> much everything.
>
> p.s. nice job getting your car BACK ON TRACK at ELVF! That was pretty 
> kool IMHO. 
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/fot/[email-masked]

---

From: [email-masked]
Date: Fri, 4 Oct 2013 11:37:46 -0400

Thanks for the great info Glenn
Robert I hope you are talking about getting back on track at RA by welding up
the frame in the paddock and not my turn 14 excursion .....which was very cool
too.....not sure who at RA I should bill for putting those 2 corn furrows in
...lol

Sent from my iPhone

On 2013-10-04, at 9:13 AM, Glenn Franco <[email-masked]> wrote:

> I contacted the owner of this company directly last year. They are a local
company near Detroit, Mi
> The floor pans are not comparable to the British Motor Heritage floor pans
available from the British Parts Suppliers.
> If you have the body off, I would not recommend these as they do not have
the ~3" downstanding flange that connects to the lower rocker.
> I would consider this a patch panel to drop in rather than a factory repair
part.
IMHO.
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: EDWARD BARNARD <[email-masked]>
Date: Fri, 4 Oct 2013 20:13:01 -0700 (PDT)

Group: Earlier this year I bought a new (to me) car trailer and had to take
the TR250 that was on it. I have been selling off the parts on Ebay. In the
collection of "stuff" was a set of rockers from this company. They can best be
described as poor examples. The metal is so thin I think my welder would have
a hard time to not blow holes in it even on the lowest setting. They sell
these for $99, and I felt happy to get $25 for the pair. I am currently
putting in a set of BMH floorpans in a customers "6" and these make the others
companies product look like scrap metal.
JMHO
-Ed- 
________________________________
 From: "[email-masked]"
<[email-masked]>
To: Glenn Franco <[email-masked]> 
Cc:
"[email-masked]" <[email-masked]> 
Sent: Friday, October 4, 2013 10:37
AM
Subject: Re: [Fot] Floor pans

Thanks for the great info Glenn
Robert I
hope you are talking about getting back on track at RA by welding up
the frame
in the paddock and not my turn 14 excursion .....which was very cool
too.....not sure who at RA I should bill for putting those 2 corn furrows in
...lol

Sent from my iPhone

company near Detroit, Mi
> The floor pans are soft
tooled (Big 3 engineering term for temp tools).
> The floor pans are not
comparable to the British Motor Heritage floor pans
available from the British
Parts Suppliers.
> If you have the body off, I would not recommend these as
they do not have
the ~3" downstanding flange that connects to the lower
rocker.
> I would
consider this a patch panel to drop in rather than a factory repair
part.
FYI
>> Part of me wonders if they picked up the
tooling from one of the body panel
fabricators from "back in the day". The
names escape me, but I used to have a
couple of catalogs back in the 80's from
at least a couple of companies that
made panels and partial panels for pretty
much everything.
Regards,
IMHO.
Former NER Solo Chair                          |
>> [email-masked]
http://www.fot-racing.com/
http://www.fot-racing.com/
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]
http://www.fot-racing.com/

Archive:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]