Subject: [Fot] Video from Charlotte

From: Mike Munson <[email-masked]>
Date: Wed, 21 Aug 2013 13:08:58 -0700 (PDT)

While we are sharing videos, heres one from my race at Charlotte this past
weekend.
You can also see fellow FOTer Joe Downer (Chumpcar Tr6) in a black
Midget.

       http://youtu.be/vJvtUaXk-u0
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Russell Westfall <[email-masked]>
Date: Wed, 21 Aug 2013 16:59:32 -0700 (PDT)

Amici
I have a three bedroom suite at Osthoffs starting Thursday night for the Kup weekend. Unfortunately, I have had some attrition in my group. I have two rooms available if anyone is interested. 
Contact me at [email-masked] or 612 991 3418 if interested.
Russ Westfall
_______________________________________________
[email-masked]