Subject: Re: [Fot] HANS

From: Duncan Charlton <[email-masked]>
Date: Thu, 1 Aug 2013 08:16:28 -0500

$599 for the NecksGen that I have been using for about a year.  Free shipping
from this company: http://tinyurl.com/l7zpewj

Duncan
(Texas)

On Jul 31, 2013, at 7:20 PM, Rocky Entriken wrote:

> $645 (and free shipping) at Saferacer for HANS Sport Series II --
http://www.saferacer.com/hans-device-sport-series-ii-hans-device
> --Rocky
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Duncan Charlton <[email-masked]>
Date: Thu, 1 Aug 2013 09:37:16 -0500

Perhaps mine is a later version; it has slip-straps, although it still does
restrict my ability to turn my head slightly.  I neglected to mention we did a
group buy of 6 here in central Texas -- Bob Kramer did the deed for us.

Duncan

On Aug 1, 2013, at 9:15 AM, michael kowalski wrote:

> However, the NecksGen that I have does not have "slip-straps" like the HANS
was described having.  I was trapped between stations once with no ability to
see traffic for re-entry because I could not swivel my head.  Very worrisome.
>
> mike kowalski
> 1500 FP Spit
>
>
> On Thu, Aug 1, 2013 at 7:16 AM, Duncan Charlton
<[email-masked]> wrote:
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: "FoodDude" <[email-masked]>
Date: Thu, 1 Aug 2013 15:08:02 -0500

The model 20 Sport is $545 and free shipping from Pegasus
https://www.pegasusautoracing.com/productselection.asp?Product=9592-020

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Rocky Entriken
Sent: Wednesday, July 31, 2013 7:20 PM
To: Bill Tobin; [email-masked]
Subject: Re: [Fot] HANS

--Rocky

(No, I don't work for SafeRacer, but I'm a customer.)

----- Original Message -----
From: "Bill Tobin" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, July 31, 2013 7:04 AM
Subject: [Fot] HANS

> My 2 cents worth: If you aren't wearing a HANS, or similar device, you 
> should
> be. They aren't restrictive, and are easy to get in and out of. And give a
> measure of confidence and safety.
> At around $700, they aren't cheap, but that would about pay for one day in
> ICU.
> After the guy crashed and was injured at Watkins Glen in June, I talked to
> someone involved in the extrication and was told his injuries would 
> probably
> have been worse than leg injuries had he not been wearing the HANS.
> Ya pays your money and takes your chances, but I try and keep as safe as
> possible.
> Cheers, Bill

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/fot/[email-masked]

-----
No virus found in this message.
Checked by AVG - www.avg.com
Version: 2013.0.3392 / Virus Database: 3209/6540 - Release Date: 07/31/13
_______________________________________________
[email-masked]

---

From: Scott Janzen <[email-masked]>
Date: Thu, 01 Aug 2013 16:17:26 -0400

I got the Sport II last year.  For you drivers in open cars, it won't matter,
but in my GT6, I had borrowed a regular Sport to try, and found the squared
off corners on the "collar" tended to catch me on the door opening when I
exit.  The Sport II worked better (of course, it costs more).

On Aug 1, 2013, at 4:08 PM, FoodDude wrote:

-----Original Message-----

--Rocky

----- Original Message -----
From: "Bill Tobin" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, July 31, 2013 7:04 AM
Subject: [Fot] HANS

-----

---

From: Bob Kramer <[email-masked]>
Date: Thu, 1 Aug 2013 16:56:30 -0500

I'd read about the need to turn your head at least in those situations and
even on grid. It seemed critical for us road racers to have some side to side
freedom thus we selected the NecksGen. I've been happy with mine.

Bob Kramer
Sent from my iPhone

> http://www.saferacer.com/hans-device-sport-series-ii-hans-device
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Greg And Alison Blake <[email-masked]>
Date: Thu, 1 Aug 2013 18:59:50 -0600

Ditto. After one event, I didn't notice a difference. Very happy with
purchase. Of course, it delayed the purchase of a gear set.

> http://autox.team.net/mailman/options/fot/[email-masked]
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: "MadMarx" <[email-masked]>
Date: Fri, 2 Aug 2013 18:24:35 +0200

I tried once a HANS without the sliding straps.
After turning the head I was blind because the helmet didn't turn and the
visor was now on my left ear.

That's whay I purchased a sliding HANS. :-)

Chris

-----Urspr|ngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im
Auftrag von Greg And Alison Blake
Gesendet: Freitag, 2. August 2013 03:00
An: Bob Kramer
Cc: [email-masked]
Betreff: Re: [Fot] HANS

On Aug 1, 2013, at 3:56 PM, Bob Kramer <[email-masked]> wrote:

> I'd read about the need to turn your head at least in those situations
> and even on grid. It seemed critical for us road racers to have some
> side to
side

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: "R. John Lye" <[email-masked]>
Date: Fri, 2 Aug 2013 13:28:07 -0400

Then the helmet was way, way too big.  There's no way
that a properly fitted helmet should allow your head
to rotate that much.

John

On Fri, August 2, 2013 12:24 pm, MadMarx wrote:
> http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Bob Kramer <[email-masked]>
Date: Fri, 2 Aug 2013 12:40:35 -0500

Good point!

Bob Kramer
Sent from my iPhone

---

From: michael kowalski <[email-masked]>
Date: Thu, 1 Aug 2013 08:15:50 -0600

However, the NecksGen that I have does not have "slip-straps" like the HANS
was described having.  I was trapped between stations once with no ability
to see traffic for re-entry because I could not swivel my head.  Very
worrisome.

mike kowalski
1500 FP Spit

On Thu, Aug 1, 2013 at 7:16 AM, Duncan Charlton <[email-masked]

---

From: Todd Redmond <[email-masked]>
Date: Fri, 02 Aug 2013 16:08:36 -0400 (EDT)

FoT

I use the Isaac Head and Neck system. B It is SFI 38.1 safe as required.
B Side to side movement is a little restricted but probably a 30deg
movement on either side. B No complaints with anything, comfort or
otherwise.B 
Quick exit too!

http://www.isaacdirect.com/html/product.html

My 2 cents
Todd

On Fri, Aug 02, 2013 at 01:40 PM, Bob Kramer wrote:

> Good point!
>
> Bob Kramer
> Sent from my iPhone
>
> On Aug 2, 2013, at 12:28 PM, "R. John Lye"  wrote:
>
>>> On Aug 1, 2013, at 3:56 PM, Bob Kramer  wrote:
>>>
>>>> On Aug 1, 2013, at 8:16 AM, Duncan Charlton
>>>>
>>>> wrote:
>>>>
>>>>> $599 for the NecksGen that I have been using for about a year.
>>>>> Free
>>>> shipping
> http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "MadMarx" <[email-masked]>
Date: Sat, 3 Aug 2013 00:19:09 +0200

It was a test helmet on a trade fair. :-)
I just sat down on the racing seat and tried it out when my sight went gone.

-----Urspr|ngliche Nachricht-----
Von: R. John Lye [mailto:[email-masked]]
Gesendet: Freitag, 2. August 2013 19:28
An: MadMarx
Cc: 'Greg And Alison Blake'; 'Bob Kramer'; [email-masked]
Betreff: Re: [Fot] HANS

Then the helmet was way, way too big.  There's no way that a properly fitted
helmet should allow your head to rotate that much.

John

On Fri, August 2, 2013 12:24 pm, MadMarx wrote:
> After turning the head I was blind because the helmet didn't turn and
> the visor was now on my left ear.
>
>> I'd read about the need to turn your head at least in those
>> situations and even on grid. It seemed critical for us road racers to
>> have some side to
> side

---

From: Tony Drews <[email-masked]>
Date: Fri, 02 Aug 2013 20:35:49 -0500

I run a HANS that was a gift from some concerned folks.  It has the 
sliding strap system.  Barely notice it while running, can turn my 
head as much as I care to.

I suspect that if Uncle Jack had been wearing a HANS that I'd still 
be racing with him...  'nuff said.

Tony Drews

---

From: Mike Mehl <[email-masked]>
Date: Fri, 2 Aug 2013 20:51:20 -0700 (PDT)

I ditto Tony's insight.  I have run the HANS both while driving the Rabbit
(with a roof) and the TR4.  I only notice it at pre-grid.  Never notice it is
even on while on the track.  

________________________________
 From: Tony
Drews <[email-masked]>
To: [email-masked] 
Sent: Friday, August 2,
2013 6:35 PM
Subject: Re: [Fot] HANS

I run a HANS that was a gift from
some concerned folks.  It has the 
sliding strap system.  Barely notice it
while running, can turn my 
head as much as I care to.

I suspect that if
Uncle Jack had been wearing a HANS that I'd still 
be racing with him... 
'nuff said.

Tony Drews

Donate:
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]