Subject: [Fot] Road America

From: Joe Alexander <[email-masked]>
Date: Sun, 11 Aug 2013 14:03:26 -0500

I am sure everyone is watching ALMS on ABC.

It's your turn next.......

Sent from my iPad
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: The Fooddude <[email-masked]>
Date: Sun, 11 Aug 2013 15:34:37 -0500

Pompelly 2nd in gtc. B Go spenser (he and jim norman took 2nd yesterday at r a in the rolex).

Sent via and typos courtesy wireless handheld device.

-------- Original message --------
From: Duncan Charlton <[email-masked]> 
Date: 08/11/2013  3:01 PM  (GMT-06:00) 
To: fot Triumph <[email-masked]> 
Subject: Re: [Fot] Road America 
 
Go DeltaWing!
Duncan