Subject: [Fot] Lifetime Rear Mount for Triumph TR3, TR4, early TR6

From: Joe Alexander <[email-masked]>
Date: Sun, 28 Jul 2013 10:17:40 -0500

We have more of these Heavy Duty rear mounts available if there is any
interest.

They are very impressive and going into some very interesting cars.

Profit? Naw!

 It will likely take a couple years to recover development and tooling costs.

It's what we do.
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: TR4 Tony <[email-masked]>
Date: Mon, 29 Jul 2013 09:20:53 +0100

Joe

Got mine today - looks good so going in something special.

Regards

Tony

Sent from my iPhone

On 28 Jul 2013, at 16:17, Joe Alexander <[email-masked]> wrote:

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]