Subject: Re: [Fot] Clutch Failure in GT6

From: "Rocky Entriken" <[email-masked]>
Date: Sat, 27 Jul 2013 00:33:08 -0500

I ripped out the centers of 3 or 4 stock clutch discs in my Spitfire before 
someone pointed me to the "competition" disk with a solid center. I'd 
imagine there's one for the GT6 too. Got mine from West Michigan Imports 
(Duane Bailey, a Spitfire racer) -- 616-878-5774 or [email-masked]

(Since then I've gone to a Quartermaster clutch setup.)

--Rocky Entriken

----- Original Message ----- 
From: "Scott Janzen" <[email-masked]>
To: "'Friends of Triumph' Triumph" <[email-masked]>
Sent: Friday, July 26, 2013 9:35 PM
Subject: [Fot] Clutch Failure in GT6

>I ran the Schenley Park GP in Pittsburgh this past weekend - a fantastic
> event, racing on city streets- I'll be back.
> It is, however, hard on the car, and once again I've found the weak link.
> The clutch disc center basically ripped out - the metal around only one of
> three rivets was still intact.
> So, it's a stock disc and pressure plate, never given trouble before, 
> probably
> on its 3rd-4th season.  Should I just replace it, or is there an easily
> adaptable upgrade that's stronger?
>
> It's an 8-1/2" disc, 23 spline - the car has a TR4-6 gearbox in it (the 
> GT6
> box was the old weak link) and a good aluminum flywheel I got from Ted 
> that
> I'd hate to give up on.
>
> What is being used out there - given that I have a TR4-6 box with the
> cross-shaft/fork arrangement, I'm guessing whatever you TR4 racers have 
> done
> might work too.
>
> Scott
> _______________________________________________
> [email-masked]
>
> http://www.fot-racing.com
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: "Bill Tobin" <[email-masked]>
Date: Sat, 27 Jul 2013 06:49:55 -0400

Scott, I had Ted have a HD disc made for me a couple years ago by his 
supplier: it worked well.
Bill
----- Original Message ----- 
From: "Scott Janzen" <[email-masked]>
To: "'Friends of Triumph' Triumph" <[email-masked]>
Sent: Friday, July 26, 2013 10:35 PM
Subject: [Fot] Clutch Failure in GT6

> http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Mike Munson <[email-masked]>
Date: Sat, 27 Jul 2013 07:42:38 -0500

After many years of tearing up stock type clutches I changed over to a Tilton
dual disc setup. It was expensive up front but WAY cheaper in the long run.
I think Sam Halkias may have a better setup on all is his TR6s.

Mike
#28 EP TR6

Sent from my iPhone

---

From: "MadMarx" <[email-masked]>
Date: Sat, 27 Jul 2013 22:55:29 +0200

I might have already said it but I run a Tilton single disc setup.

Chris

-----Urspr|ngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im
Auftrag von Mike Munson
Gesendet: Samstag, 27. Juli 2013 14:43
An: Scott Janzen
Cc: 'Friends of Triumph' Triumph
Betreff: Re: [Fot] Clutch Failure in GT6

After many years of tearing up stock type clutches I changed over to a
Tilton dual disc setup. It was expensive up front but WAY cheaper in the
long run.
I think Sam Halkias may have a better setup on all is his TR6s.

Mike
#28 EP TR6

Sent from my iPhone

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]