Subject: Re: [Fot] Clutch Failure in GT6. Now The Clutch Doctor.

From: Joe Alexander <[email-masked]>
Date: Sun, 28 Jul 2013 10:05:44 -0500

Clutch Doctor is where we went.

! Extremely impressed with the design, construction, features, and performance
of the Clutch Doctor clutch.

Price is right as well.

Thanks to John and Russ.......

I didn't realize what an expert John Hagen is on clutches. I guess that would
be a further endorsement.

I think there is a picture of the unit is around somewhere....perhaps Sean has
it.

Sent from my iPad

On Jul 28, 2013, at 9:49 AM, [email-masked] wrote:

> We have found a one person shop in North Branch Mn--"The Clutch Doctor"--he
can build most anything.  We us a"One Piece" disc--no rivets-no 'Marcel" with
ceramic buttons.  Don't need "Marcel" in the fins for smooth takoffs--ie
street.  Ceramic buttons run cooler and can take more oil. Must use steel
insert if using aluminum flywheel.  Sprung center section is advised for road
racing--ie not solid disc.
>   I used to build my our clutches when I worked for a clutch manufacturer.
We built 100M units per year.  I used to give clinics on clutches---sooo
Questions 763-684-1617.  John Hagen  TR-4 -  TVR Grantura
>  Clutch Doctors' name is Trevor  @  651-674-4175
>
> On Fri, Jul 26, 2013 at 9:35 PM, Scott Janzen wrote:
>
>> I ran the Schenley Park GP in Pittsburgh this past weekend - a fantastic
>> event, racing on city streets- I'll be back.
>> It is, however, hard on the car, and once again I've found the weak link.
>> The clutch disc center basically ripped out - the metal around only one of
>> three rivets was still intact.
>> So, it's a stock disc and pressure plate, never given trouble before,
probably
>> on its 3rd-4th season.  Should I just replace it, or is there an easily
>> adaptable upgrade that's stronger?
>>
>> It's an 8-1/2" disc, 23 spline - the car has a TR4-6 gearbox in it (the
GT6
>> box was the old weak link) and a good aluminum flywheel I got from Ted
that
>> I'd hate to give up on.
>>
>> What is being used out there - given that I have a TR4-6 box with the
>> cross-shaft/fork arrangement, I'm guessing whatever you TR4 racers have
done
>> might work too.
>>
>> Scott
>> _______________________________________________
>> [email-masked]
>>
>> http://www.fot-racing.com
>>
>> Donate: http://www.team.net/donate.html
>> Archive: http://www.team.net/archive
>> Forums: http://www.team.net/forums
>> Unsubscribe/Manage:
http://autox.team.net/mailman/options/fot/[email-masked]
> _______________________________________________
> [email-masked]
>
> http://www.fot-racing.com
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: John Hasty <[email-masked]>
Date: Sun, 28 Jul 2013 12:50:07 -0400

Same advice the engineer @ SPEC gave me. Sprung center for RR. We have used
their stage 3 unit for almost three yrs. no problems.

Sent from my iPhone

probably
GT6
that
done
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: SCOTT JANZEN <[email-masked]>
Date: Sun, 28 Jul 2013 13:09:28 -0400

Great advice - I was hoping there was an alternative to a solid center clutch.
The close ratio gear set yields a really tall first gear, and a little give
(i.e., sprung disc) would seem to be easier on the drivetrain overall.

Sent from my mobile device

probably
GT6
that
done