Subject: [Fot] Randy Williams. 2012 KCUP recipient

From: Joe Alexander <[email-masked]>
Date: Wed, 3 Jul 2013 08:36:16 -0500

Fot:

Does anyone have contact information for Randy?

Of course we will want to know if he will be with us at Road America.

Thanks,

Joe A.

Sent from my iPad
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Tony Drews <[email-masked]>
Date: Wed, 03 Jul 2013 10:19:52 -0500

"Randy Williams" <[email-masked]>

Tony Drews

At 08:36 AM 7/3/2013, Joe Alexander wrote:
>Donate: http://www.team.net/donate.html
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: 
>http://autox.team.net/mailman/options/fot/[email-masked]