Subject: Re: [Fot] gt6 clutch

From: Jason Ostrowski <[email-masked]>
Date: Tue, 9 Jul 2013 09:11:12 -0500

Probably a mix of asbestos and horse hair...
It will be fine.
Jason Ostrowski
Friendly Ghost Racing

On Mon, Jul 8, 2013 at 8:34 PM, Bobby Whitehead <[email-masked]> wrote:

> any reason to think the UNIPART Laycock clutch disc would not work? Very
> light
> tan material surface...  Bobby
> _______________________________________________
> [email-masked]
>
> http://www.fot-racing.com
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Joe Alexander <[email-masked]>
Date: Tue, 9 Jul 2013 09:22:59 -0500

Once again, there is a shop in Minnesota that is doing competition grade
clutches that one of the Minnesota guys put us on to.

Superior materials and oil resistance.

I think Sean has been very happy with it and he has the address.

Joe A

Sent from my iPad

>> tan material surface...  Bobby
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Scott Janzen <[email-masked]>
Date: Tue, 09 Jul 2013 11:25:05 -0400

I've never had an issue with the stock GT6 clutch plates (or the TR7 one now
running with the TR6 trans and GT6 flywheel set-up).
BTW, I do have an NOS Borg and Beck pressure plate and disc in the box - disc
splines compatible with the GT6, but not the Tr6 trans I now use.
Any interest let me know.

On Jul 9, 2013, at 10:11 AM, Jason Ostrowski wrote: