Subject: [Fot] Renault Clio Cup Round 4 from Donington Park Apr 2013 - YouTube

From: Keith Files <[email-masked]>
Date: Wed, 8 May 2013 14:44:55 +0100

Dear all, thought you might like to see what my son gets up to in the UK,
enjoy

Keith

http://m.youtube.com/watch?v=VUCjkJxEMJc
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Tony Drews <[email-masked]>
Date: Fri, 10 May 2013 19:40:00 -0500

Wow.  That was a great drive by Josh!  You must be proud.

Cheers, Tony Drews

At 08:44 AM 5/8/2013, Keith Files wrote:
>Donate: http://www.team.net/donate.html
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: 
>http://autox.team.net/mailman/options/fot/[email-masked]