Subject: [Fot] Sadly a Sign of the times-

From: [email-masked]
Date: Fri, 29 Mar 2013 01:25:53 +0000

Another... I went to local pep boys for a 6 volt battery.  (It was for a 1914 cadillac I have.)  The fellow asks what car and year.  I tell him.  He can't find it in computer, Duh. Then I say its for a 1932 Model A ford.   Not in computer either. Ok I say... Do you have  any 6 volt batteries?  I don't know he says.  Can you look? What do they look like? 

M

Sent via BlackBerry from T-Mobile
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Vince G <[email-masked]>
Date: Thu, 28 Mar 2013 14:29:06 -0400

Not everyone is up on antiques, especially the younger folk LOL

Us old farts luv'm

Sent from my iPhone

On 2013-03-28, at 12:11 PM, "Craig Leinicke" <[email-masked]>
wrote:

> To add to this thread, a couple of years ago I asked the same 20+ year old
> counter clerk at a local auto parts store about rear shock absorbers for a
> Triumph TR7... He looked me square in the eye and said "Who makes Triumph?"
>
> When I replied... "Triumph makes Triumph" he looked at me like I had just
> stepped off a space ship and had a third eye in the middle of my forehead.
>
> Needless to say, I didn't buy any parts that day. I understand that this
> fellow probably wasn't born in 1981 when Triumph production came to an end
> but you would think anyone with enough interest to work in the automotive
> field would recognize major British auto manufacturers.
>
> The reality is that all of us have more knowledge about the workings of
> automobiles than 90% of the people working the auto parts counters today.
>
> Craig Leinicke
> Flashback Racing
>
>
> On 3/28/13 3:35 AM, "Spitfire Racing" <[email-masked]> wrote:
>
>> I can remember when there were some 9 auto parts stores in this area and
>> everyone of them had people that knew their stuff and many were motorheads
>> who contributed expertise and experiences over the counter. On top of
this,
>> they had everything imaginable even if it was on a back shelf under a
layer
>> of dust. Oh, and might I add that everything was Made in USA back then and
>> it always fit. Now there are three "chain" stores that have 35 different
>> smelling dash ornaments, wax and googahs and any part is from some third
>> world country and two days away. There's a 50/50 chance it will fit and
>> function.
>> Welcome to the ugly new world. It's not confined to auto parts
>> stores.........
>> Me, I long for the way it was back 40-50 years ago. On many levels!
>>
>> Russ Moore
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of [email-masked]
>> Sent: Wednesday, March 27, 2013 11:03 PM
>> To: FOT
>> Subject: [Fot] Sadly a Sign of the times-
>>
>> I went to my local auto zone today.  Behind the counter a clerk perhaps
>> 28y/o asked me what he could get for me.  I asked "Where do you have your
>> timing lights?".  He looked at me then calmly went to the computer and
asked
>> "What year and model?".
>>
>> I should have known better.  I was there a couple of months ago. At that
>> time I asked for rod bearings for a small block chevy. it was a different
>> clerk similarly aged.  He asked "What year and model?".  I said "1972
>> chevelle 350".  He responds "front bearings?"
>> "No- all of them" I say. "Both sides?" He queries. Then I get this "a ha"
>> moment when I seriously believed we are doing an Abbott and Costello
"who's
>> on first".  So I tell him " I don't think you understand" - "Engine rod
>> bearings standard size".  So he looks at me and says. "What's that?".  I
>> look at my son and then back at the clerk and say "I made a mistake I
>> thought this was an auto store".  We walked out.
>>
>> I am going to write to their corporate office.
>>
>> M
>> Donate: http://www.team.net/donate.html
>> Forums: http://www.team.net/forums
>> Unsubscribe/Manage:
>> http://autox.team.net/mailman/options/fot/[email-masked]
>> Donate: http://www.team.net/donate.html
>> Forums: http://www.team.net/forums
>> Unsubscribe/Manage:
>> http://autox.team.net/mailman/options/fot/[email-masked]
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]