Subject: [Fot] Harbor Freight

From: Bobby Whitehead <[email-masked]>
Date: Sun, 6 Jan 2013 08:25:28 -0800 (PST)

I'm not a big fan of buying stuff made in China but Harbor Freight has a sale in 
my area of N. Texas this week.... the U.S. General (U.S.?) four drawer tool cart 
580lb capacity is a real good deal at $99.99  ... I use one like it in my car 
hauler / garage.. also a 3 ton jack stand set is $15.99 ... cheap enough if you 
own several Triumphs like me, one or two is always in the air.. not mentioned 
but a purchase I made a few months back was a nice set of car dollys.. I've got 
my Spitwad rolling around in the garage on those... wish I had bought those 
years ago... you can push the car over into the tightest spaces...
Now these are toys for men and women and there has been a bunch of backlash from 
toys in China painted with lead base paint... but as adults we should know not 
to lick our Chinese tools...

Bobby 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "Jim Gray" <[email-masked]>
Date: Sun, 6 Jan 2013 11:17:17 -0700

" but as adults we should know not to lick our Chinese tools..."

Bobby you crack me up :) 
I pledge to practice safe mechanics and not lick my Chinese tools.

Jim g

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Bobby Whitehead
Sent: Sunday, January 06, 2013 9:25 AM
To: FoT Triumph
Subject: [Fot] Harbor Freight

I'm not a big fan of buying stuff made in China but Harbor Freight has a
sale in 
my area of N. Texas this week.... the U.S. General (U.S.?) four drawer tool
cart 
580lb capacity is a real good deal at $99.99  ... I use one like it in my
car 
hauler / garage.. also a 3 ton jack stand set is $15.99 ... cheap enough if
you 
own several Triumphs like me, one or two is always in the air.. not
mentioned 
but a purchase I made a few months back was a nice set of car dollys.. I've
got 
my Spitwad rolling around in the garage on those... wish I had bought those 
years ago... you can push the car over into the tightest spaces...
Now these are toys for men and women and there has been a bunch of backlash
from 
toys in China painted with lead base paint... but as adults we should know
not 
to lick our Chinese tools...

Bobby 

Archive: http://www.team.net/archive
Unsubscribe:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]