Subject: [Fot] TR8 Direction

From: Kelvin Dodd <[email-masked]>
Date: Fri, 14 Dec 2012 08:04:14 -0800

It may be sacrilege on this list, but gutting a TR8 to make a race car, when
there are limited competition venues available, to me, is a bit of a waste.

I remember the first time I got my TR8 on the road. It started to rain and I
realized that the car had wipers and a defrost system that actually worked
effectively!

The TR8 is a really great road car. It is capable of dusting the majority of
classic British sports cars, yet is comfortable and still a great value.

Just don't think of it as a Triumph. It's not. Just as the Rover SD1 is not a
Rover. Both cars are British Leyland designs, that got badged to fit a market
niche. They have to be appreciated as stand alone designs, without the
heritage (and hand me down engineering) of the earlier marques.

I'm with TeriAnn, get in the car and see where your dreams take you.

You can access an excellent TR7/8 group through this web link.

http://www.team.net/TR8/Mailing-List.html

Kelvin Dodd
1980 TR8
1980 SD1
Other stuff

________________________________
 From: Shawn Frank <[email-masked]>
To: "[email-masked]" <[email-masked]>
Sent: Thursday, December 13, 2012 11:29 AM
Subject: [Fot] Forums

Excuse my ignorance, but how do I get to the forums such as the TR8 forum on
Friends of Triumph? I can't seem to find it on the website. Is there a link
I can follow to explore the different email lists or forums? Thank you in
advance, and sorry this is not competition related. This is the only forum I
can find right now..Shawn _______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

From: "Robert M. Lang" <[email-masked]>
To: "Shawn Frank" <[email-masked]>
Cc: [email-masked]
Sent: Thursday, December 13, 2012 7:28:04 AM
Subject: Re: [Fot] TR8 direction

Hi,

There's a "wedge" mail list that might be a place to fish for advice on
TR8's... you might want to sign up for that.

My vote: race car.

The sale price of TR8's is hovering at close to zero, so if you buy one
and toss bags -o -money at it, you'll still have a TR8 worth close to
zero. Sad, ut true.

That said, there's a bunch of folks on the wedge list that cater to TR8
and B performance, so it's a pretty good place to start.

regards,
rml
Message: 6
Date: Fri, 14 Dec 2012 05:41:16 -0700
From: "TeriAnn J. Wakeman" <[email-masked]>
To: [email-masked]
Subject: Re: [Fot] TR8 direction

On 12/13/12 10:27 PM, Bobby Whitehead wrote:
> I'm with Jim... my late father used to say "never let emotion get involved
in a
> business decision" .
And then there is my way of making decisions:  "Do everything with
passion and compassion" It lets you live life like you mean it.

My suggestion is to sit inside the TR8, behind the wheel.  One hand on
the steering wheel, one on the shift knob.  Just sit there for a while
and see where your day dreams take you.  Then follow your dreams.

TeriAnn
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "Bill Tobin" <[email-masked]>
Date: Fri, 14 Dec 2012 12:04:50 -0500

Hi All,
If anyone really wants a TR7, I have one. '77, 5 speed, interior good, body 
decent, low compression on #4 cylinder.
Make me a reasonable offer.
(I can't get out of the darned thing! Tough getting old!
Bill
----- Original Message ----- 
From: "Kelvin Dodd" <[email-masked]>
To: <[email-masked]>
Sent: Friday, December 14, 2012 11:04 AM
Subject: [Fot] TR8 Direction

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe: 
> http://autox.team.net/mailman/options/fot/[email-masked]
>
>
>
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe: 
> http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Joe Alexander <[email-masked]>
Date: Fri, 14 Dec 2012 12:07:36 -0500 (EST)

Kelvin, is right, according to John Clancy's well done DVD histories on
Triumphs.

I think I remember seeing a MG 'trial badge' on a TR7 while watching his DVD
on TR7/8s.

That being said, they still are in our TRIUMPH FAMILY and I suspect we need to
bring them into vintage racing.

A 'spec' category such as Henry suggests seems like good place to start.

Kudos to Shawn Frank for launching this thread.  A couple of years ago, it
might not have gone anywhere. Its time has come?

Once again, I recommend the John Clancy series on TRIUMPH HISTORY.

-----Original Message-----
From: Kelvin Dodd <[email-masked]>
To: [email-masked]' <[email-masked]>
Sent: Fri, Dec 14, 2012 10:04 am
Subject: [Fot] TR8 Direction

Kelvin Dodd
1980 TR8
1980 SD1
Other stuff

---

From: Bud R <[email-masked]>
Date: Fri, 14 Dec 2012 10:52:15 -0700

And I have a BOP 215 V8 engine that could go in it or any of the wedges

I'd entertain unreasonable offers just to move it into the mix.

Bud Rolofson

71TR6 CC57365 (Good 6)
71 Spitfire MK IV Race Car #3
66TR4A CTC57529 (The Project)
71F-250 Camper Special (Triumph Support Vehicle)
Z-50A Hardly Davidson 1977 Honda Mini-Trail Bike (Triumph Pit Bike)

On Dec 14, 2012, at 10:04 AM, Bill Tobin wrote:

> Hi All,
> If anyone really wants a TR7, I have one. '77, 5 speed, interior  
> good, body decent, low compression on #4 cylinder.
> ----- Original Message ----- From: "Kelvin Dodd"  
> <[email-masked]>
> To: <[email-masked]>
>> can find right now..Shawn  
>> Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]
> Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Tony and Annie Garmey <[email-masked]>
Date: Fri, 14 Dec 2012 10:01:58 -0800

if you really want to see how a  TR8 should go, search out "Tony Pond" on
youtube from the early/mid 80's in the UK rally championship.  The ulster and
manx rally's.
 > To: [email-masked]; [email-masked]
> From: [email-masked]
> Date: Fri, 14 Dec 2012 12:07:36 -0500
> Subject: Re: [Fot] TR8 Direction
>
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Joe Alexander <[email-masked]>
Date: Fri, 14 Dec 2012 13:07:53 -0500 (EST)

I was also highly entertained by what BUFFETT and his wife did on rallies

Joe Alexander
A. R. E.
645 1st Street
Jesup, Iowa 50648
319.464.4711  (cell)
[email-masked]

-----Original Message-----
From: Tony and Annie Garmey <[email-masked]>
To: n197tr4 <[email-masked]>; doddk <[email-masked]>; fot
<[email-masked]>
Sent: Fri, Dec 14, 2012 12:01 pm
Subject: RE: [Fot] TR8 Direction

---

From: robert bownes <[email-masked]>
Date: Fri, 14 Dec 2012 13:21:38 -0500

John Buffham...awesome driver in the TR7-V8 and the Audi Quattro Coupe.

I'm still looking for a BOP/Rover V8 for the formula car project. I've got
the chassis, intake manifold and camshaft so far... :)

Bob

On Fri, Dec 14, 2012 at 1:07 PM, Joe Alexander <[email-masked]> wrote:

> > That being said, they still are in our TRIUMPH FAMILY and I suspect we
> need
> to
> > I remember the first time I got my TR8 on the road. It started to rain
> and
> I
> > Just don't think of it as a Triumph. It's not. Just as the Rover SD1 is
> not
> a
> Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Joe Alexander <[email-masked]>
Date: Fri, 14 Dec 2012 13:25:06 -0500 (EST)

senior moment ...yes,   BUFFUM   no Margaritaville here.

Joe Alexander
A. R. E.
645 1st Street
Jesup, Iowa 50648
319.464.4711  (cell)
[email-masked]

-----Original Message-----
From: robert bownes <[email-masked]>
To: Joe Alexander <[email-masked]>
Cc: horizonracing <[email-masked]>; doddk <[email-masked]>; fot
<[email-masked]>
Sent: Fri, Dec 14, 2012 12:21 pm
Subject: Re: [Fot] TR8 Direction

I'm still looking for a BOP/Rover V8 for the formula car project. I've got the
chassis, intake manifold and camshaft so far... :)

Bob

Joe Alexander
A. R. E.
645 1st Street
Jesup, Iowa 50648
319.464.4711  (cell)
[email-masked]

-----Original Message-----
From: Tony and Annie Garmey <[email-masked]>
To: n197tr4 <[email-masked]>; doddk <[email-masked]>; fot
<[email-masked]>

---

From: Kelvin Dodd <[email-masked]>
Date: Fri, 14 Dec 2012 10:29:34 -0800

This is one of John Buffum's ex works TR7s that was being rallied in New
Mexico in 1984. It had been converted to a V8 by the owner.

http://s460.photobucket.com/albums/qq327/Kelvin13/Stuff/?action=view&current=
Oct8413.jpg

My mediocre claim to automotive fame was to crash about 1 mile past where John
Buffum's Audi had broken down during the 1981 Centennial National Pro Rally.

http://s460.photobucket.com/albums/qq327/Kelvin13/Stuff/?action=view&current=
Sept81.jpg

Kelvin Dodd
________________________________________
From: Joe Alexander [mailto:[email-masked]]
Sent: Friday, December 14, 2012 10:08 AM
To: [email-masked]; Kelvin Dodd; [email-masked]
Subject: Re: [Fot] TR8 Direction

Joe Alexander
A. R. E.
645 1st Street
Jesup, Iowa 50648
319.464.4711  (cell)
[email-masked]

-----Original Message-----
From: Tony and Annie Garmey <[email-masked]>
To: n197tr4 <[email-masked]>; doddk <[email-masked]>; fot
<[email-masked]>

---

From: "Richard Taylor" <[email-masked]>
Date: Fri, 14 Dec 2012 13:40:12 -0500

I trying to catch up on this thread, I stumbled onto:

        DC Shoes: Ken Block's Gymkhana Five

Google it. It's staggering!

Richard Taylor

---

From: Joe Alexander <[email-masked]>
Date: Fri, 14 Dec 2012 13:41:05 -0500 (EST)

Kelvin, it sure looks like you, only much younger.....thanks!

Joe Alexander
A. R. E.
645 1st Street
Jesup, Iowa 50648
319.464.4711  (cell)
[email-masked]

-----Original Message-----
From: Kelvin Dodd <[email-masked]>
To: 'Joe Alexander' <[email-masked]>; [email-masked]'
<[email-masked]>; [email-masked]' <[email-masked]>
Sent: Fri, Dec 14, 2012 12:29 pm
Subject: RE: [Fot] TR8 Direction

This is one of John Buffum's ex works TR7s that was being rallied in New
Mexico
in 1984. It had been converted to a V8 by the owner.

Kelvin Dodd

Joe Alexander
A. R. E.
645 1st Street
Jesup, Iowa 50648
319.464.4711  (cell)
[email-masked]

-----Original Message-----
From: Tony and Annie Garmey <[email-masked]>
To: n197tr4 <[email-masked]>; doddk <[email-masked]>; fot
<[email-masked]>