Subject: Re: [Fot] John Fitch

From: John Wagner <[email-masked]>
Date: Thu, 1 Nov 2012 05:41:10 -0700 (PDT)

I had the opportunity to meet John Fitch at Elkhart Lake a few years ago.
What pleasant person to talk to. He signed my Aug. Elkhart Lake  road race
program,which he won
the big bore class in a Cunningham. The racing community
has lost a true hero. My thoughts and prays go out to him and his family.

     John Wagner (just the wrench)  

----- Original Message -----
From:
EDWARD BARNARD <[email-masked]>
To: FOT <[email-masked]>
Cc:
Sent: Wednesday, October 31, 2012 9:54 PM
Subject: [Fot] John Fitch

The FOT
has been very quiet with many of its members at the VTR Nationals in Galveston
Texas. For those who may not have heard, John Fitch passed away this morning.
With his passing goes a great fighter pilot, sports car driver, Indy car
driver, and a member of the Cunningham team at LeMans with Phil Walters during
the big crash in '55.
RIP
-Ed-
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate:
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
Unsubscribe:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "Clark W. Nicholls" <[email-masked]>
Date: Thu, 1 Nov 2012 09:00:18 -0400

Great article on John here:

http://www.autoweek.com/article/20121031/ALMS/121019873 

Clark
Clark W. Nicholls
1972 Stag (LE7931E) for sale, 1974 Spitfire (FM14571U) 
and 1 rusty GT6 needing new owner KC 5577 L
www.botchagaloop.net for old racing photos
"Reality, it's not what you think." 
_______________________________________________
[email-masked]