Subject: [Fot] Fw: John Fitch

From: Ed Diehl <[email-masked]>
Date: Thu, 1 Nov 2012 15:13:29 -0700 (PDT)

Ed Diehl

----- Forwarded Message -----
From: Ed Diehl
<[email-masked]>
To: fot <[email-masked]> 
Sent: Thursday, November
1, 2012 12:04 PM
Subject: John Fitch

Hello, all.    I was very sorry to
hear about the passing of Jon Fitch. He was not only a great driver,
pilot,etc, but he was a genuine nice guy. Some years back I had the pleasure
to be on the stage with him at the Glen Theater in Watkins Glen . I was
honored to be invited to speak, along with John Fitch, Bob Lutz, and Bill
Millican at the Vintage Grand Prix. That part of the event is called "Legends
Speak". What an honor!! He was a very pleasant man and his wife was a quite a
nice Lady. Never forget it!  Cheers, Ed

Ed Diehl
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Kas Kastner <[email-masked]>
Date: Fri, 2 Nov 2012 01:49:48 +0000

I've had long conversations with John in various places in the world and he
was a just a very nice man,.  FAST too. I'm big on FAST.

Never be beaten by equipment
 > Date: Thu, 1 Nov 2012 15:13:29 -0700
> From: [email-masked]
> To: [email-masked]
> Subject: [Fot] Fw: John Fitch
>
>
> Ed Diehl
>
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Ed Diehl <[email-masked]>
Date: Fri, 2 Nov 2012 09:13:35 -0700 (PDT)

Ed Diehl

----- Forwarded Message -----
From: Ed Diehl
<[email-masked]>

Hello, all.    I was very sorry to
hear about the passing of John Fitch. He was not only a great driver,
pilot,etc, but he was a genuine nice guy. Some years back I had the pleasure
to be on the stage with him at the Glen Theater in Watkins Glen . I was
honored to be invited to speak, along with John Fitch, Bob Lutz, and Bill
Milligan at the Vintage Grand Prix. That part of the event is called "Legends
Speak". What an honor!! He was a very pleasant man and his wife was a quite a
nice Lady. Never forget it!  Cheers, Ed

Ed Diehl