Subject: [Fot] Best distributor/ignition for TR4

From: Scott Janzen <[email-masked]>
Date: Sat, 20 Oct 2012 11:27:33 -0400

The folks at Electromotive tell me the very elegant crank triggered ignition on my EP TR4 is not firing correctly throughout the rpm range. As I may take this car back to vintage, I'm looking for a distributor-based replacement.  So, should it be Mallory with electronic guts, given reported quality issues with Lucas replacement caps, etc?  Other thoughts?  And, if you have a known good set-up you want to sell, let me know.

---

From: [email-masked]
Date: Sat, 20 Oct 2012 11:45:50 -0400 (EDT)

We've seen some strange maladies with the Mallory Electronics.  I  don't 
think you can beat the points Mallory for performance and  reliability.
 
For the Herald based cars you order the Jag distributor.  Not sure if  the 
TR4's are the same....

>From [email-masked]  Sat Oct 20 11:15:15 2012
From: John Houlton <[email-masked]>
Date: Sat, 20 Oct 2012 12:12:38 -0500
To: Scott Janzen <[email-masked]>
Cc: Triumph 'Friends of Triumph' <[email-masked]>
Subject: Re: [Fot] Best distributor/ignition for TR4

Pertronix.  I threw my Mallory deep into the woods.
John