Subject: Re: [Fot] Quarter Master clutches (spitfire)

From: "[email-masked]" <[email-masked]>
Date: Thu, 03 May 2012 18:29:04 -0400

Wht size clutch?....I run the QM 5 1/2,woith single disc ppro rally disc..domt use tje dbl disc metallic,unless yu like  drag racing

Sent from my HTC on the Now Network from Sprint!

----- Reply message -----
From: [email-masked]
Date: Thu, May 3, 2012 5:14 pm
Subject: [Fot] Quarter Master clutches (spitfire)
To: "Friends of Triumph" <[email-masked]>

I use a Tilton unit. Nice thing and very quick shifting.
Gesendet mit BlackBerry von Vodafone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "MadMarx" <[email-masked]>
Date: Fri, 4 May 2012 00:35:34 +0200

It is a 7 B<b clutch with titanium pressure plate. 2.5 kg for the whole unit
including disc.

The clutch plate has no springs. But these type of plate better not be used on
a stock gearbox, only on a straight cut gear set.

Cheers

Chris

Von: [email-masked] [mailto:[email-masked]]
Gesendet: Freitag, 4. Mai 2012 00:29
An: [email-masked]; Friends of Triumph
Betreff: Re: [Fot] Quarter Master clutches (spitfire)

Wht size clutch?....I run the QM 5 1/2,woith single disc ppro rally disc..domt
use tje dbl disc metallic,unless yu like  drag racing