Subject: [Fot] 2010 Watkins Glen in-car

From: dick stockton <[email-masked]>
Date: Sat, 19 May 2012 18:27:48 -0400

Here is video from my car at Watkins Glen battling with my old friend Bob
Leitzinger and his Datsun 510. Keep an eye on the mirror. Enjoy.

http://www.youtube.com/watch?v=tjLMkZLJoyA

Dick
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: John Hasty <[email-masked]>
Date: Sat, 19 May 2012 22:09:27 -0400

I was there and watched the race from Ceasar's cam. Good fun. Convinced me to
jump in the Frey with a TR 3A the next year.....

Sent from my iPhone

On May 19, 2012, at 6:27 PM, dick stockton <[email-masked]> wrote:

> Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]