Subject: Re: [Fot] Quarter Master clutches (spitfire)

From: [email-masked]
Date: Thu, 3 May 2012 21:14:24 +0000

I use a Tilton unit. Nice thing and very quick shifting.
Gesendet mit BlackBerry von Vodafone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 03 May 2012 19:14:50 -0400

Agree...i use a houseman/toyota comp tranny mod...un breakable

Sent from my HTC on the Now Network from Sprint!