Subject: [Fot] FP Reg

From: John Hasty <[email-masked]>
Date: Mon, 28 May 2012 13:05:36 -0400

What kind of fuel pressure reg. are you all using?  I am now on the 2nd Holly
and with it set @ 3lbs in the pits, it moves from 2 to 8 out on the track when
we tested Friday.  At anything over 3 I get a stutter coming on the gas out of
the slower turns.
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Tylerpthompson <[email-masked]>
Date: Mon, 28 May 2012 11:11:58 -0600

What carbs are you running?  I run a Holley as well.  Set it at 3 and it
doesn't go up when running. Also running HS6s.  I has to go to MGB float bowls
so that the floats were oriented front to back and not side to side. That
solved my sputtering in the slower turns.

Ty

Sent from my iPhone

On May 28, 2012, at 11:05 AM, John Hasty <[email-masked]> wrote:

> Unsubscribe:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: Tony Drews <[email-masked]>
Date: Mon, 28 May 2012 12:22:26 -0500

After much experimentation, Jack and I ended up with the combination 
of a Holley Blue fuel pump with the Holley low pressure regulator.

A common problem with fuel pressure regulators is that there's not 
enough pressure differential between input and output to reliably 
operate the regulator.  The Holley Blue puts out 14 psi, and I have 
it regulated down to a rock solid 2 psi for my webers.

https://www.pegasusautoracing.com/productdetails.asp?RecID=2516
https://www.pegasusautoracing.com/productselection.asp?Product=1135

With low pressure pumps, we repeatedly had a problem where fuel 
delivery would shut down at the end of long straights and we'd end up 
pulling the regulator to make it through the weekend.  Having high 
enough pressure to operate the regulator seems to be key.

Tony

At 12:05 PM 5/28/2012, John Hasty wrote:
>Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "Greg \"Lunker\" Hilyer" <[email-masked]>
Date: Mon, 28 May 2012 12:21:21 -0600

John,
My guess is that for a pressure swing like that there might be a  
venting problem. Does the fuel cell ever have any pressure when you  
remove the cap?[it shouldn't].
My cheapo "clicker" type pump has been clicking away a steady and  
unregulated 2.5psi for many years now - in fact, if I know me, it was  
probably used when I put it in.
My $.02
Greg "Lunker" Hilyer
TR4 #314
Albuquerque NM
On May 28, 2012, at 11:05 AM, John Hasty wrote:

> Unsubscribe: http://autox.team.net/mailman/options/fot/ 
> [email-masked]

---

From: sherry robyn <[email-masked]>
Date: Mon, 28 May 2012 11:39:21 -0700 (PDT)

Greg, not to devert from the current discussion but I have a 12 gal. fuel cell
from Summit and when sitting it always has pressure when I remove the cap if
the 
day has any kind of warmth at all.  Can't say that I've pulled the cap
when it 
is running.  I thought that pressure was normal.  Would you think
that my relief 
valve is not relieving near enough?  Jim
________________________________
From: "Greg "Lunker" Hilyer"
<[email-masked]>
To: John Hasty <[email-masked]>
Cc: Friends of
Triumph <[email-masked]>
Sent: Mon, May 28, 2012 11:21:39 AM
Subject: Re:
[Fot] FP Reg

John,
My guess is that for a pressure swing like that there
might be a venting 
problem. Does the fuel cell ever have any pressure when
you remove the cap?[it 
shouldn't].
My cheapo "clicker" type pump has been
clicking away a steady and unregulated 
2.5psi for many years now - in fact,
if I know me, it was probably used when I 
put it in.
My $.02
Greg "Lunker"
Hilyer
TR4 #314
Albuquerque NM
> Forums: http://www.team.net/forums
Unsubscribe:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]
http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive:
http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

---

From: [email-masked]
Date: Mon, 28 May 2012 16:09:30 -0400 (EDT)

My "cheapo clicker" (Facet Pump?) has done the same.  Hope the gods don't kill the poor thing now that I've sounded off. 

----- Original Message -----
From: "Greg \"Lunker\" Hilyer" <[email-masked]>
To: "John Hasty" <[email-masked]>
Cc: "Friends of Triumph" <[email-masked]>
Sent: Monday, May 28, 2012 12:21:21 PM
Subject: Re: [Fot] FP Reg

John,

Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "Tim Murphy" <[email-masked]>
Date: Mon, 28 May 2012 17:22:09 -0500

Fuel Pressure Regulator - Holley  Part No. 12-803 (included with pump)
Pressure range 4-1/2 to 9 psi
      Set to 3-1/4 to 3-1/2 PSI

Fuel Pump - Holley "Blue" Part No. 12-802-1  (70 gph at 9 psi, preset
pressure 14 psi)

Fuel Filter - Fram HPG-1

Carburetors - SU Type H6

This was all at the suggestion of Uncle Jack and Tony when we built the car.
The fuel pressure has always been rock solid.  I think we may have dropped
the pressure to a bit under 3 PSI.  I'll have to take a look when I get the
engine together and back in the car running.

Tim & Ryan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of John Hasty
Sent: Monday, May 28, 2012 12:06 PM
To: Friends of Triumph
Subject: [Fot] FP Reg

What kind of fuel pressure reg. are you all using?  I am now on the 2nd
Holly
and with it set @ 3lbs in the pits, it moves from 2 to 8 out on the track
when
we tested Friday.  At anything over 3 I get a stutter coming on the gas out
of
the slower turns.
_______________________________________________
[email-masked]

http://autox.team.net/mailman/options/fot/[email-masked]

---

From: TR4 Tony <[email-masked]>
Date: Tue, 29 May 2012 09:26:52 +0100

I run twin (switchable) facet red top electric pumps and I don't get any such
problems.

The reason I have two and they are switchable from the dash is that as they
wear they tend to 'stick', so I just flip the switch and use the other until I
can pull the duff one out. I got 8 years an about 50000 rally miles from the
first two ..... So that's the service life of those pumps I suppose.

Regards

Tony

Sent from my iPhone

On 28 May 2012, at 21:09, [email-masked] wrote:

> My "cheapo clicker" (Facet Pump?) has done the same.  Hope the gods don't
kill the poor thing now that I've sounded off.
> Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]