Subject: [Fot] Powermax/Hepolite pistons

From: Bob Davis <[email-masked]>
Date: Thu, 03 May 2012 06:15:37 -0400

Can anyone tell me if the Powermax/Hepolite pistons of the 70's and 80's 
are cast or forged?

thxx,
Bob
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: [email-masked]
Date: Thu, 3 May 2012 16:28:30 -0400 (EDT)

Bob-

Those pistons are cast.  What are you tryin to build...and more importantly
how far ya gonna rev that puppy?
I've used those pistons in quite a few motors "back in the day" and with an
"F" cam ya really wound it up...never had a problem with the pistons.  Well
actually had several problems with the pistons breaking, but it was usually
because the remnants of the rod impacted the side of the skirts!

Type cast myself...
Nick in Nor Cal

-----Original Message-----
From: Bob Davis <[email-masked]>
To: fot <[email-masked]>
Sent: Thu, May 3, 2012 3:43 am
Subject: [Fot] Powermax/Hepolite pistons

Can anyone tell me if the Powermax/Hepolite pistons of the 70's and 80's
re cast or forged?
thxx,
ob
______________________________________________
[email-masked]
http://www.fot-racing.com
Donate: http://www.team.net/donate.html
rchive: http://www.team.net/archive
orums: http://www.team.net/forums
nsubscribe: http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]