Subject: [Roadsters] Calipers & rotors

From: [email-masked]
Date: Sat, 25 Jul 2026 21:18:03 -0400

Hello.

I have a 1970 SR311 that needs calipers and rotors due to sitting too
long. Any recommendations for Vendors?

Also will need new carpeting.

Thank you for any and all suggestions.

Richard Bunnell
Belmont, NY

P.S.  Anybody close to14813?
________________________________________

[email-masked]

Archive: http://www.team.net/pipermail/datsun-roadsters http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/datsun-roadsters/[email-masked]

---

From: Pete <[email-masked]>
Date: Sun, 26 Jul 2026 07:53:29 -0700

Did you check 311s.og? There are multiple stock and non-stock options. 

Pete 

Sent via BlackBerry Hub+ Inbox for Android

-----Original Message-----  	
From: [email-masked]
Sent: July 26, 2026 5:40 AM
To: [email-masked]
Subject: [Roadsters] Calipers & rotors

Hello.

Richard Bunnell
Belmont, NY

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/datsun-roadsters http://autox.team.net/archive