Subject: [Roadsters] Roadster sighting

From: Gary McCormick via Datsun-roadsters <[email-masked]>
Date: Thu, 1 Jul 2021 10:12:01 -0700

Walking my dog this morning, at about 9:15, I spotted a red Roadster, 
year and model unknown, eastbound on Willow St in San Jose, approaching 
Lincoln Ave. Anyone on the list?

Gary McCormick
1970 2000 Roadster
SRL311-13291
San Jose, CA
________________________________________

[email-masked]

Archive: http://www.team.net/pipermail/datsun-roadsters http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/datsun-roadsters/[email-masked]

---

From: Richard Bush via Datsun-roadsters <[email-masked]>
Date: Fri, 2 Jul 2021 11:28:07 -0500

Good morning,

I have a 2000 Datsun and a couple of questions for the group:

1) The brake light on my car is alway on and has drained the battery to the point where I need a new battery. I think it's the switch. Does anyone know where I can buy a new brake light switch? I am assuming the switches are generic and work on any Fairlady model and year.
2) One of the four bolts that hold the wheel on the car has broken off. Are the bolts loose and therefore, easily replaceable or are they fixed to the car? Does anyone know where I can buy a new bolt/lug nut?

Thank you and have a fabulous and safe weekend.
________________________________________