Subject: [Roadsters] Carb cleaner recommendations

From: Pat Horne via Datsun-roadsters <[email-masked]>
Date: Sun, 17 May 2020 11:35:52 -0500

I know that the solvents we used to be able to get did a much Better job than the new stuff. 

I had a old can of chem-dip from the 90’s that worked great. The can finally rusted through & needed replacement. Berryman still lists the chem-dip with the same part number but it isn’t the same stuff. I soaked a fuel pump in it for 12 hours & all it did was slightly soften the grease. The rest of the pump still looks like it did when I put it in. 

Is there a product or home brew today that works?

Peace,
Pat

Pat Horne 
We support Habitat for Humanity

________________________________________

[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/datsun-roadsters http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/datsun-roadsters/[email-masked]

---

From: Mark Miller via Datsun-roadsters <[email-masked]>
Date: Thu, 21 May 2020 16:35:24 -0700

McMaster Carr will send it to you:

https://www.mcmaster.com/toluene

Regards,

Mark Miller   707-490-5834
[email-masked]

> Try toluene.  It is flame-able and bad to breath.  Must use in an open
> space.   White water rafters use it to clean boats before repairing.  Shops
> such as Northwest River Supply in Moscow, Idaho sells it in quart
> containers.  Otherwise it is hard to find because of the danger it poses.
>
> STEVE  WEBBER
>
>