Subject: Re: [Roadsters] OT - Rust Treatment & Paint?

From: Pat Horne via Datsun-roadsters <[email-masked]>
Date: Sun, 10 May 2020 12:44:58 -0500

I’ve used ospho on the Exterior steel stairs I built in 2005. I then painted over it with red metal primer. The steel was new but had some rust & scale on it that I wire wheeled. Haven’t had any problems with rust, though I did just repaint to change color. 

Peace,
Pat

Pat Horne 
We support Habitat for Humanity

On May 10, 2020, at 12:34 PM, Ronnie Day via Datsun-roadsters <[email-masked]> wrote:

I'm cleaning up and rebuilding a locally built, wood decked utility trailer. Typical angle iron/tube frame construction. The original paint is worn, a lot, and there's considerable surface rust. I took it to the quarter car wash and cleaned it up as best I could.

I'm not inclined to have the whole thing media blasted so the plan is, doing a section at a time, to use wire brushes and a detail sander to remove as much of the loose paint as I can, and then hit that area with rattle can primer/paint to "seal/convert" the rust I can't get off, then move to the next section.

Realizing there are products out there that supposedly work like magic, what actually does a decent job? I'm looking for durability and protection, not a car show finish.

RD
________________________________________

[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/datsun-roadsters http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/datsun-roadsters/[email-masked]

________________________________________

[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/datsun-roadsters http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/datsun-roadsters/[email-masked]

---

From: RWM via Datsun-roadsters <[email-masked]>
Date: Sun, 10 May 2020 13:55:36 -0400

I've used POR-15 liquid (pricey, and difficult to work with), Rustoleum Rust Converter spray, and Loctite Rust Neutralizer spray, all to good long-term effect.

As with all paint application, surface preparation is the key.

- Bob

> On May 10, 2020, at 13:35, Ronnie Day via Datsun-roadsters <[email-masked]> wrote:
> 
> 
> Unsubscribe: http://autox.team.net/mailman/options/datsun-roadsters/[email-masked]
> 
>