Subject: Re: [Roadsters] Mechanical Fuel Pump. Used Toyota pickup truck's

From: [email-masked]
Date: Sat, 19 Jul 2014 09:23:18 -0500 (CDT)

In keeping with all things Japanese, ( I kid).  I found that a fuel pump from a Toyota taco  pick up worked .
The only thing that I had the change was the top half of the fuel pump housing where the inlet and outlet spook out .  

If I remember correctly, the spl311's I'm
Melt and outlet are 180 degrees to each other , but the Toyota was at some weird 53 degrees to each other.

I just switched the housings by unscrewing the 6 or  8 screws that held the housings together,   The actuator lever that sticks into the side of the motor and rubs against the crank shaft ( I think) was the same length and angle - a perfect match.   :- ).  

That problem cured - I now have to send my carbs off to ztherapy for them to rebuild.  $$. Say bucks "

Good luck. 

Cam

On 07/18/14, jim roosevelt wrote:

Where can I get a mechanical fuel pump for a 1969 1600 roadster (or a rebuild
kit)? I tried Dealer=NA; O'Rielly, Auto Zone, Pep Boys = no listing.
RockAuto
had a listing ( BWD/NIEHOLL #41453, ordered one and it was not even close. (
It looks like the one for a Nissan 510 AIRTEX # 1069.) It will be going back.
Thanks,
Mike
________________________________________

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/datsun-roadsters/[email-masked]
________________________________________

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/datsun-roadsters/[email-masked]

---

From: Roy Haslett <[email-masked]>
Date: Sat, 19 Jul 2014 10:54:04 -0700

Interesting, I'm having issue with my fuel pump at the moment.
What year
Toyota Tacoma are we talking for a mechanical fuel pump?  Did you have to use
a spacer block?
Thanks,
Roy H.
67 1600

On Saturday, July 19, 2014 7:24 AM,
"[email-masked]" <[email-masked]> wrote:

In keeping with
all things Japanese, ( I kid).  I found that a fuel pump from a Toyota taco 
pick up worked .
The only thing that I had the change was the top half of the
fuel pump housing where the inlet and outlet spook out .  

If I remember
correctly, the spl311's I'm
Melt and outlet are 180 degrees to each other ,
but the Toyota was at some weird 53 degrees to each other.

I just switched
the housings by unscrewing the 6 or  8 screws that held the housings
together,   The actuator lever that sticks into the side of the motor and rubs
against the crank shaft ( I think) was the same length and angle - a perfect
match.   :- ).  

That problem cured - I now have to send my carbs off to
ztherapy for them to rebuild.  $$. Say bucks "

Good luck. 

Cam

On 07/18/14,
jim roosevelt wrote:

Where can I get a mechanical fuel pump for a 1969 1600
roadster (or a rebuild
kit)? I tried Dealer=NA; O'Rielly, Auto Zone, Pep Boys
= no listing.
RockAuto
had a listing ( BWD/NIEHOLL #41453, ordered one and it
was not even close. (
It looks like the one for a Nissan 510 AIRTEX # 1069.)
It will be going back.
Thanks,
Mike
________________________________________
[email-masked]

Archive: http://www.team.net/archive
Unsubscribe:
http://autox.team.net/mailman/options/datsun-roadsters/[email-masked]
________________________________________

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe:
http://autox.team.net/mailman/options/datsun-roadsters/[email-masked]
________________________________________