Subject: [British-cars] Dash Painting/P.Coating

From: <[email-masked]>
Date: Thu, 9 Jan 2014 10:10:45 -0600

I know I am not the first to think of trying this so I would again implore
the List for BTDT wisdom.
 
I am thinking of either painting or powder coating the dash on my current
TR3 project, but curious as to what others have done with the cubby box
door.  So far, my only solution is making an aluminium panel to replace the
vinyl covered wood that is currently there.
 
All thoughts and pictures appreciated,
 
Cheers,
Bill
 
Bill Beecher
'58 TR3A TS/30766L "Tarbaby"
'62 TR3B TCF/2549L " Aunt B" (in rehab)
 <http://www.triumphowners.com/1566> www.triumphowners.com/1566
'68 Land Rover Series IIa 88" "The Beast"
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: "Pete Ryner" <[email-masked]>
Date: Thu, 09 Jan 2014 11:35:17 -0500

My TR is mostly original but I took some liberties and changed my dash and 
glove box cover to wood veneer.  Using veneer I was able to keep the dash 
center metal back so it would still provide the ground for the electrical. 
I use pour over poly that is much like the AH 3000 dash.  Matched both with 
a piece of bird eye maple which I think gives it a touch of class but can 
still be easily returned to original if necessary.  I never did like the 
vinyl covered wood.
I can send you a picture if you want.
Pete

-----Original Message----- 
From: [email-masked]
Sent: Thursday, January 09, 2014 11:10 AM
To: [email-masked] ; [email-masked]
Subject: [TR] Dash Painting/P.Coating

Cheers,
Bill

Bill Beecher

** [email-masked] **

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked] 
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: Carl TR <[email-masked]>
Date: Thu, 09 Jan 2014 11:43:38 -0600 (CST)

the one issue I found when I powder coated the dash and center insert.  I needed to be sure to ground to something other than the coated surface (or grind off the pc) otherwise the ground was hit/miss....
 
I covered in vinyl so can't help with the cubby question.

Carl
1961 TR3A - TS81802LO
mysite.verizon.net/cfmtr3a
Tampa, Florida

On 01/09/14, [email-masked] wrote:

Cheers,
Bill

Bill Beecher